summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorloh.tar2022-04-09 18:09:53 +0200
committerloh.tar2022-04-09 18:09:53 +0200
commitc9b3c09d1509cb00e55b152399b20f3395cf3ea2 (patch)
tree174bcfcaf52c4d86ae1d3bac4220725c7f5385f5 /PKGBUILD
downloadaur-c9b3c09d1509cb00e55b152399b20f3395cf3ea2.tar.gz
Hello Arch-World!
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0d16466ece27
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: loh.tar <loh.tar at googlemail dot com>
+pkgname="wrt2pdf"
+pkgver="0.6"
+pkgrel="1"
+pkgdesc="Create a PDF out of a plain text file"
+arch=("x86_64")
+url="https://github.com/loh-tar/$pkgname"
+license=("GPL2")
+depends=("qt5-base")
+source=("$pkgname-$pkgver.tar.gz::https://github.com/loh-tar/$pkgname/archive/v$pkgver.tar.gz")
+sha256sums=('f204671e76bac20c4e039d4bec8bd7a52bdc69c2b62ce68d48ebadd29d8f8a87')
+
+build() {
+ cd "$pkgname-$pkgver"
+ mkdir build
+ cmake -DCMAKE_BUILD_TYPE=Release -S "./" -B "build"
+ cd build
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 "build/wrt2pdf" "${pkgdir}/usr/bin/wrt2pdf"
+# install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
+}