summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormatheuz12102021-08-30 21:47:26 -0300
committermatheuz12102021-08-30 21:47:26 -0300
commit79decbee84dd149a6da4081173623a67d41b9bd6 (patch)
tree299c13f2916e581eab2ad07c720d22cba488668b /PKGBUILD
downloadaur-79decbee84dd149a6da4081173623a67d41b9bd6.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b3701e3cd922
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: matheuz1210 <matheuz1210 at gmail dot com>
+
+pkgname=wsid
+pkgver=0.1
+pkgrel=1
+pkgdesc='web show image directory'
+arch=(any)
+url='https://github.com/matheuz1210/wsid'
+license=(GPL)
+depends=(
+ 'python>=3.9' )
+makedepends=(
+ git )
+optdepends=(
+ 'python-pyqt5: for gui' )
+source=(
+ "${pkgname%-git}::git+${url}#tag=${pkgver}" )
+b2sums=(SKIP)
+
+package(){
+ cd "${srcdir}/${pkgname%-git}"
+ install -Dm755 wsid -t "${pkgdir}/usr/bin"
+}