summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMaksim Fomin2019-08-10 14:04:42 +0000
committerMaksim Fomin2019-08-10 14:04:42 +0000
commited139fbfbc36275f2b2c7d8c81fe30c6d939cb15 (patch)
treedcfc88ab4b267f6bc2f5e33111ec64cd79be33af /PKGBUILD
parent48d07b478499f0c8037ef2e2dd7714a4d1d0de63 (diff)
downloadaur-ed139fbfbc36275f2b2c7d8c81fe30c6d939cb15.tar.gz
Add support for polkit; add gksu as optdepends
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 13 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 960fd04f60f8..9981885cefca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,26 @@
# Maintainer: Steven Honeyman <stevenhoneyman at gmail com>
+# Maintainer: Maxim Fomin <maxim at fomin one>
pkgname=wxhexeditor
pkgver=0.24
-pkgrel=2
+pkgrel=3
pkgdesc="A free hex editor / disk editor for Linux, Windows and MacOSX"
arch=('i686' 'x86_64')
url="http://www.wxhexeditor.org"
license=('GPL2')
depends=('wxgtk3')
makedepends=('python')
-source=("https://github.com/EUA/wxHexEditor/archive/v$pkgver.tar.gz")
-md5sums=('1b77bddc026e22797fd0e7a82e52cd28')
+optdepends=('gksu: For root access support'
+ 'polkit: For root access support')
+source=("https://github.com/EUA/wxHexEditor/archive/v$pkgver.tar.gz"
+ "01-add-pkexec-support.patch")
+md5sums=('1b77bddc026e22797fd0e7a82e52cd28'
+ 'e62ae9e6b0aac2afdcc41b51cab39272')
+
+prepare() {
+ cd "$srcdir/wxHexEditor-$pkgver"
+ patch -Np1 -i "${srcdir}/01-add-pkexec-support.patch"
+}
build() {
cd "$srcdir/wxHexEditor-$pkgver"