summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoan Bruguera2019-02-28 13:11:38 +0100
committerJoan Bruguera2019-02-28 13:11:38 +0100
commitbf196d6475d9176041696c42ca12c54ed4b84a2c (patch)
tree559ac35faeee426e2506df7848948cf344ba0e17 /PKGBUILD
parent63367d178ba640c436bbec8a8a31aa93eda2ad3f (diff)
downloadaur-bf196d6475d9176041696c42ca12c54ed4b84a2c.tar.gz
Clean up and simplify PKGBUILD.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9147dc416a70..791097c5f6f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,27 +2,28 @@
pkgname='wxparaver'
pkgdesc='Expressive powerful and flexible trace visualizer for post-mortem trace analysis (from BSC).'
pkgver='4.8.1'
-pkgrel='2'
+pkgrel='3'
arch=('i686' 'x86_64')
url='https://www.bsc.es/discover-bsc/organisation/scientific-structure/performance-tools'
license=('LGPLv2.1')
depends=('wxgtk3' 'webkit2gtk' 'boost')
-source=(https://ftp.tools.bsc.es/wxparaver/wxparaver-4.8.1-src.tar.bz2
- wxParaver.desktop)
+source=("https://ftp.tools.bsc.es/$pkgname/$pkgname-$pkgver-src.tar.bz2"
+ "wxParaver.desktop")
sha512sums=(80481fc75b977f85476658e25e9d091530f64f1b04b15d826715fb5e9646c33c14e46ef8d5233f1b57c442895cf96206b8812bded482f58dce76888745cc88e6
f1b000ea660765bbd454d9ae54d360233389121e54f8bcab241420b42aefa4f679735500efd43afdcd932f3a7bd339f00ff299f755a62163c1c3e34bd6920f6e)
-build() {
+prepare() {
cd "$srcdir/$pkgname-$pkgver"
# FIXME: By default, it seems that the wxParaver depends on an existing -kernel/-api installation
cd src/wxparaver
sed -i 's|-lparaver-kernel -lparaver-api|-L../../paraver-kernel/src/.libs -L../../paraver-kernel/api/.libs -lparaver-kernel -lparaver-api|g' src/Makefile.am
sed -i 's|^wxparaver_bin_CXXFLAGS =.*|& -I../../paraver-kernel -I../../paraver-kernel/api|' src/Makefile.am
- aclocal
- automake --add-missing
- autoconf
- cd ../..
+ autoreconf -i -f
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
# Arch's wx-config is named differently for GTK2/GTK3
./configure \