summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorase15902017-01-08 01:38:42 -0600
committerase15902017-01-08 01:38:42 -0600
commit2aed389badd3a8b63650b1f5feb5147412c10f33 (patch)
tree726dc2c927011c5ac8dc2bdd6c458f0591c3f345 /PKGBUILD
downloadaur-2aed389badd3a8b63650b1f5feb5147412c10f33.tar.gz
added both files, used makepkg --printsrcinfo > .SRCINFO to generate .SRCINFO
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a4569714d0ff
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Allen M. <ase1590@hotmail.com>
+
+pkgname=wxpython-phoenix-git
+pkgver=r2748.gcd8da03c
+pkgrel=1
+pkgdesc="Python 3 implementation of the WxPython UI library"
+arch=('x86_64' 'i686')
+url="https://github.com/wxWidgets/Phoenix"
+license=('custom:wxWindows')
+depends=('python' 'wxgtk')
+makedepends=('mesa' 'glu' 'git' 'libpng' 'libjpeg-turbo' 'webkitgtk2' 'libtiff' 'sdl' 'gstreamer0.10-base-plugins' 'libnotify' 'freeglut' 'gtk2')
+source=("$pkgname::git+${url}"
+ "git+https://github.com/wxWidgets/wxWidgets.git")
+md5sums=('SKIP' 'SKIP')
+provides=('wxpython-phoenix')
+conflicts=('wxpython-phoenix-bin')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ printf 'r%s.g%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare(){
+ cd "$srcdir/$pkgname"
+ git submodule init
+ git config submodule.ext/wxWidgets.url "$srcdir/wxWidgets"
+ git submodule update
+}
+
+build(){
+ cd "$srcdir/$pkgname"
+ python build.py dox etg --nodoc sip
+}
+
+package(){
+ cd "$srcdir/$pkgname"
+ python setup.py install --root="$pkgdir/"
+ cd "$pkgdir/usr/bin/"
+ for file in *
+ do
+ mv "$file" "${file%}-phoenix"
+ done
+ cd "$srcdir/$pkgname/ext/wxWidgets/docs"
+ install -D -m644 licence.txt $pkgdir/usr/share/licenses/wxpython-phoenix/license.txt
+}