summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorase15902017-07-22 10:45:55 -0500
committerase15902017-07-22 10:45:55 -0500
commita7b55bced3f4424aebe5125b5c3b4b5a101943b9 (patch)
tree31010976096eb14342579543121c3e227baf673a /PKGBUILD
parent4888d4150b6ed5a8098ebe5838123db345a084dd (diff)
downloadaur-a7b55bced3f4424aebe5125b5c3b4b5a101943b9.tar.gz
updated build to use gtk3 and webkit2gtk
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e51dcec7f522..643619a8744a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Allen M. <ase1590@hotmail.com>
pkgname=wxpython-phoenix-git
-pkgver=r2752.g8304ec1b
+pkgver=r3225.g172bd50d
pkgrel=1
pkgdesc="Python 3 implementation of the WxPython UI library"
arch=('x86_64' 'i686')
url="https://github.com/wxWidgets/Phoenix"
license=('custom:wxWindows')
depends=('python' 'wxgtk')
-makedepends=('mesa' 'glu' 'git' 'libpng' 'libjpeg-turbo' 'webkitgtk2' 'libtiff' 'sdl' 'gst-plugins-base' 'libnotify' 'freeglut' 'gtk2')
+makedepends=('mesa' 'glu' 'git' 'libpng' 'libjpeg-turbo' 'libtiff' 'sdl' 'gst-plugins-base' 'libnotify' 'freeglut' 'gtk3' 'webkit2gtk')
source=("$pkgname::git+${url}"
"git+https://github.com/wxWidgets/wxWidgets.git")
md5sums=('SKIP' 'SKIP')
@@ -29,12 +29,12 @@ prepare(){
build(){
cd "$srcdir/$pkgname"
- python build.py dox etg --nodoc sip
+ python build.py dox etg --nodoc sip build --gtk3
}
package(){
cd "$srcdir/$pkgname"
- python setup.py install --root="$pkgdir/"
+ python setup.py install --skip-build --root="$pkgdir/"
cd "$pkgdir/usr/bin/"
for file in *
do