summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGustavo Parreira2022-10-22 02:05:15 +0100
committerGustavo Parreira2022-10-22 02:05:15 +0100
commit1e13b7817855c873f28e9c5aa0fe5566224a49d5 (patch)
treec8ebdf040f34206d50434d675af15bf07228c7f7 /PKGBUILD
parent55c3656a528784aec24ef69bf5f2208b6fac281f (diff)
downloadaur-1e13b7817855c873f28e9c5aa0fe5566224a49d5.tar.gz
fix: no longer overriding system wlroots
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 7 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f699cb0bd287..5f4a37964564 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_basename='wxrd'
pkgname="$_basename-git"
pkgver=0.16.0.r46.a548783
-pkgrel=2
+pkgrel=3
pkgdesc="A prototype-quality standalone client for xrdesktop based on wlroots and the wxrc codebase."
arch=('i686' 'x86_64')
url="https://gitlab.freedesktop.org/xrdesktop/wxrd"
@@ -21,7 +21,7 @@ depends=(
'python3'
)
makedepends=('git' 'meson' 'vulkan-headers' 'gtk-doc' 'pygobject-devel')
-provides=("$_basename" 'wlroots' 'xrdesktop' 'gulkan' 'gxr')
+provides=("$_basename" 'xrdesktop' 'gulkan' 'gxr')
conflicts=("$_basename")
source=(
'git+https://gitlab.freedesktop.org/xrdesktop/wxrd.git'
@@ -58,17 +58,15 @@ prepare() {
build() {
rm -rf build
- arch-meson $_basename build --libdir=lib -Ddefault_library=static
+ arch-meson $_basename build --libdir=lib \
+ --force-fallback-for=gulkan,gxr,xrdesktop,wlroots \
+ -Ddefault_library=static
ninja -C build
}
package() {
- DESTDIR="$pkgdir" ninja -C build install
+ meson install -C build --skip-subprojects wlroots --destdir "$pkgdir"
cd "$_basename"
- install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE.wxrd
- install -Dm644 subprojects/wlroots/LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE.wlroots
- install -Dm644 subprojects/gulkan/LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE.gulkan
- install -Dm644 subprojects/gxr/LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE.gxr
- install -Dm644 subprojects/xrdesktop/LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE.xrdesktop
+ install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
}