summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGustavo Parreira2022-10-21 20:02:54 +0100
committerGustavo Parreira2022-10-21 20:02:54 +0100
commit55c3656a528784aec24ef69bf5f2208b6fac281f (patch)
tree4a63eb0982259a507a82f64e46fd3846df4358c7 /PKGBUILD
parent325fdacdc71064e4c892fcbaeab5da8a772e17ec (diff)
downloadaur-55c3656a528784aec24ef69bf5f2208b6fac281f.tar.gz
chore: explicilty added python3 as runtime dependency
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 12 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 815dc6aa4ab1..f699cb0bd287 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_basename='wxrd'
pkgname="$_basename-git"
pkgver=0.16.0.r46.a548783
-pkgrel=1
+pkgrel=2
pkgdesc="A prototype-quality standalone client for xrdesktop based on wlroots and the wxrc codebase."
arch=('i686' 'x86_64')
url="https://gitlab.freedesktop.org/xrdesktop/wxrd"
@@ -17,6 +17,8 @@ depends=(
'graphene' 'shaderc' 'glfw'
# gxr
'gtk3' 'openvr' 'openxr'
+ # xrdesktop
+ 'python3'
)
makedepends=('git' 'meson' 'vulkan-headers' 'gtk-doc' 'pygobject-devel')
provides=("$_basename" 'wlroots' 'xrdesktop' 'gulkan' 'gxr')
@@ -45,9 +47,9 @@ pkgver() {
prepare() {
cd "$_basename"
- mv "$srcdir"/gulkan subprojects
- mv "$srcdir"/gxr subprojects
- mv "$srcdir"/xrdesktop subprojects
+ ln -sf "$srcdir"/gulkan subprojects/gulkan
+ ln -sf "$srcdir"/gxr subprojects/gxr
+ ln -sf "$srcdir"/xrdesktop subprojects/xrdesktop
git submodule init
git config submodule.subprojects/wlroots.url "$srcdir"/wlroots
@@ -63,5 +65,10 @@ build() {
package() {
DESTDIR="$pkgdir" ninja -C build install
- install -Dm644 "$_basename"/LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+ cd "$_basename"
+ install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE.wxrd
+ install -Dm644 subprojects/wlroots/LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE.wlroots
+ install -Dm644 subprojects/gulkan/LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE.gulkan
+ install -Dm644 subprojects/gxr/LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE.gxr
+ install -Dm644 subprojects/xrdesktop/LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE.xrdesktop
}