summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjuju21432020-02-05 18:26:44 -0500
committerjuju21432020-02-05 18:26:44 -0500
commit1ed55730521ff050871ec5cac0c729b1bfcb1e0a (patch)
tree8eea38f69ec70acf9d25e670eecfe0395b9ddd0c /PKGBUILD
parentcd4708afdf73ef97bb3022c4792f554f0911bde8 (diff)
downloadaur-1ed55730521ff050871ec5cac0c729b1bfcb1e0a.tar.gz
Changed URL to commit hash
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c92ee0c2c3ea..eb6af4e3bc57 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
# Maintainer: Julien Savard <juju@juju2143.ca>
pkgname=x16-rom
pkgver=r36
+_realpkgver=98d773e203a5e853741db323d927fbc066f2507d
pkgrel=1
pkgdesc="ROM files for The 8-Bit Guy's Commander X16"
arch=('any')
@@ -16,20 +17,20 @@ replaces=()
options=()
install=x16-rom.install
changelog=
-source=("$pkgname-$pkgver.tar.gz::https://github.com/mist64/$pkgname/archive/$pkgver.tar.gz"
+source=("$pkgname-${_realpkgver}.tar.gz::https://github.com/mist64/$pkgname/archive/${_realpkgver}.tar.gz"
"https://raw.githubusercontent.com/mist64/x16-emulator/$pkgver/github-pandoc.css")
-md5sums=('248d486c05320c7579abd7204a3f2b32'
+md5sums=('471e63a8da769a548a918ff44c32774e'
'3accdbadaf70264c743b1f655f5dc146')
build() {
- cd "$pkgname-$pkgver"
+ cd "$pkgname-${_realpkgver}"
_pkgver1=${pkgver#r}
make PRERELEASE_VERSION=${_pkgver1%%[^0-9]*}
pandoc --from gfm --to html -c github-pandoc.css --standalone --metadata pagetitle="X16 KERNAL/BASIC/DOS ROM" README.md --output KERNAL-BASIC.html
}
package() {
- cd "$pkgname-$pkgver"
+ cd "$pkgname-${_realpkgver}"
install -Dm644 rom.bin "$pkgdir/usr/share/$pkgname/rom.bin"
install -Dm644 ../github-pandoc.css "$pkgdir/usr/share/doc/$pkgname/github-pandoc.css"
install -Dm644 KERNAL-BASIC.html "$pkgdir/usr/share/doc/$pkgname/KERNAL-BASIC.html"