summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhil Sidler2021-02-21 16:47:02 -0600
committerPhil Sidler2021-02-21 16:47:02 -0600
commit2b456a5754f66486888a2c72c7a0728ee8906335 (patch)
treea2a8099b24766022d3117240e9ad6f98529e0e3a /PKGBUILD
parent891d3aff47b6b006d889f210723d76a457727c24 (diff)
downloadaur-2b456a5754f66486888a2c72c7a0728ee8906335.tar.gz
fetch license from wiki
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9302a6f13dc9..1d54f794c616 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Parts copied from x3270 package by tuftedocelot <tuftedocelot@fastmail.fm>
pkgname=x3270-git
pkgver=4.1alpha7.r2733
-pkgrel=1
+pkgrel=2
pkgdesc="IBM 3270 terminal emulator for the X Window System"
arch=('x86_64')
url="http://x3270.bgp.nu/"
@@ -16,19 +16,21 @@ install=x3270.install
source=("$pkgname::git+https://git.code.sf.net/p/x3270/code"
x3270.install
x3270.fontpath
- x3270.desktop)
+ x3270.desktop
+ $pkgname.license::'https://x3270.miraheze.org/w/api.php?action=parse&format=json&page=X3270_license&utf8=1')
sha256sums=('SKIP'
'1007f7a7a5ad41749dbc70cc7ca6e259ec7c272dd82d210d2dd0f2fca6c18444'
'3cbd44463bf70a5a5983f4fa2ef51adaf4d3e0217638fc1f7fc12c1566c31d2b'
- 'c45ded78fe9a2fe2acff1a5df53366647310165931b39bab942ab06296e13b1c')
+ 'c45ded78fe9a2fe2acff1a5df53366647310165931b39bab942ab06296e13b1c'
+ '17850aa5153b728844af4f251d56301281678a701fe32e52f521b45f2dbac9c3')
pkgver() {
cd "${srcdir}/${pkgbase}"
printf "%s.r%s" "$(sed -n 's/^version=\"\([^\"]*\)\"/\1/p' Common/version.txt)" "$(git rev-list --count HEAD)"
}
build() {
+ sed -e 's/<[^>]*>//g' -e 's/\\n/\n/g' $pkgname.license | sed -e 's/\[edit\]//g' -e 's/\\\"/\"/g' -e '/^License for.*$/,$!d' | head --lines -2 > ${pkgname}/LICENSE
cd "${pkgname}"
./configure --enable-x3270 --prefix=/usr --sysconfdir=/etc --with-fontdir=/usr/share/fonts/3270
- sed -n -e '/ * Copyright (c)/,/^$/{s/^...\(.*\)$/\1/p}' Common/copyright.c >LICENSE
make || return 1
}
package() {