summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormaze2018-04-30 12:36:30 +0200
committermaze2018-04-30 12:36:30 +0200
commitf6b46dd144306f0392de8c016cbb4e2b1aa64784 (patch)
treee44d26e6b88877a8512b945572d0820bb2700103 /PKGBUILD
parent5d70e1c30192bfd4be8439c8147926efd9aa388b (diff)
downloadaur-x84.tar.gz
Version 2.0.15
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 12 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3d7317f38d4a..b18c7f9e5371 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,30 @@
# Maintainer: Wijnand Modderman-Lenstra <maze@pyth0n.org>
pkgname=x84
-pkgver=2.0.12
+pkgver=2.0.15
pkgrel=1
pkgdesc="Telnet server for UTF-8 and cp437 terminals"
arch=(any)
url="https://github.com/jquast/x84"
license=('ISC')
groups=()
-depends=('python2' 'python2-requests' 'python2-sauce' 'python2-sqlitedict' 'python2-py-bcrypt')
+depends=(
+ 'python2'
+ 'python2-requests'
+ 'python2-sauce'
+ 'python2-sqlitedict'
+ 'python2-bcrypt'
+ 'python2-html2text'
+)
makedepends=('python2')
optdepends=()
install=
changelog=
source=(https://pypi.python.org/packages/source/x/$pkgname/$pkgname-$pkgver.tar.gz)
-md5sums=('5e8a74e9082a40677af924478872047c')
-sha1sums=('30dcd3baf50fb41910c07b1ddac325102f734bb6')
+sha1sums=('c98be9a186aad098d896055f8dbf0f431f0774e5')
+sha256sums=('59210511ac09aeab68783916a3455e10d86b65c334bbb0f3bc38ee25d57ae6f1')
package() {
cd "$srcdir/$pkgname-$pkgver"
- sed -e 's!^python !/usr/bin/env python2 !' -i bin/x84
+ sed -e 's!^python !/usr/bin/env python2 !' -i x84/engine.py
python2 setup.py install --root="$pkgdir/" --optimize=1
}