summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgrufo2021-04-14 19:07:57 +0200
committergrufo2021-04-14 19:07:57 +0200
commit3df69c5fea21ef3115c6b53dcc794b4dd542fcab (patch)
treeef3812c9269a4e3529565b065294de70cc03e7b9 /PKGBUILD
parentd8510f0d80dad05650511dd5da3ad517b17cac8f (diff)
downloadaur-3df69c5fea21ef3115c6b53dcc794b4dd542fcab.tar.gz
Service file moved from `/etc/systemd/system` to `/usr/lib/systemd/system`
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 037cd0660d95..5ae9af154a96 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
pkgname='xampp'
_srcver='8.0.3'
_binver=0
-pkgrel=1
+pkgrel=2
# This PKGBUILD deals with two different versioning formats: the upstream
# format MAJOR.MINOR.REVISION-BUILD - used internally by XAMPP - and the
# makepkg-friendly format MAJOR.MINOR.REVISION[.BUILD]-RELEASE (where the only
@@ -92,7 +92,7 @@ package() {
cd "${srcdir}"
# Package tree
- msg 'Recreating package tree...'
+ msg 'Creating package tree...'
install -dm755 "${pkgdir}${_xampp_root}"
rsync -azq --remove-source-files \
"${srcdir}/${_pkgstring}/xampp_core_files/xampp_core_folder"/. \
@@ -138,11 +138,11 @@ package() {
# Systemd files
install -dm755 \
- "${pkgdir}/etc/systemd/system" \
+ "${pkgdir}/usr/lib/systemd/system" \
"${pkgdir}/usr/lib/sysusers.d" \
"${pkgdir}/usr/lib/tmpfiles.d"
- sed "${_sed_subst}" "${srcdir}/xampp.service.in" > "${pkgdir}/etc/systemd/system/xampp.service"
+ sed "${_sed_subst}" "${srcdir}/xampp.service.in" > "${pkgdir}/usr/lib/systemd/system/xampp.service"
install -Dm644 "${srcdir}/xampp.sysusers" "${pkgdir}/usr/lib/sysusers.d/xampp.conf"
sed "${_sed_subst}" "${srcdir}/xampp.tmpfiles.in" > "${pkgdir}/usr/lib/tmpfiles.d/xampp.conf"