summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgrufo2020-09-16 04:27:01 +0100
committergrufo2020-09-16 04:27:01 +0100
commitdcae8dcb28673f16458f425ae9f6116f3631a2fa (patch)
tree6d112150c9fa1ebaa4eabd61c25e7bd1a6a9d9e4 /PKGBUILD
parentec48b03e9b51f5701fd53419d9b88fb6d5c29ff0 (diff)
downloadaur-dcae8dcb28673f16458f425ae9f6116f3631a2fa.tar.gz
PKGBUILD: use a simple symlink for the license directory
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6dece435d639..29e1f88ebce4 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
pkgname='xampp'
pkgver='7.4.10'
-pkgrel=2
+pkgrel=3
pkgdesc='A stand-alone LAMPP distribution'
url='http://www.apachefriends.org/'
license=('GPL')
@@ -94,8 +94,9 @@ package() {
msg 'Copying executables and launcher...'
# Licenses
- install -dm755 "${pkgdir}/usr/share/licenses/xampp"
- rsync -azq "${pkgdir}/opt/lampp/licenses"/. "${pkgdir}/usr/share/licenses/xampp"
+ install -dm755 "${pkgdir}/usr/share/licenses"
+ chmod -R a+rwX,g-w,o-w "${pkgdir}/opt/lampp/licenses"
+ ln -sf "/opt/lampp/licenses" "${pkgdir}/usr/share/licenses/xampp"
# Executables
install -dm755 "${pkgdir}/usr/bin"