summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel M. Capella2017-09-24 23:11:25 -0400
committerDaniel M. Capella2017-09-24 23:11:25 -0400
commit10269b744562633a0eb3647ec2d7ed6a8dc96661 (patch)
tree034b1e62f6d74e48e3addc1ce3926543c309c517 /PKGBUILD
parent30f0595b2310af1c8c6428973e6a883df1fd013a (diff)
downloadaur-10269b744562633a0eb3647ec2d7ed6a8dc96661.tar.gz
Separate build in lieu of reproducible builds
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 03b57a54ee56..be3be2e77574 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,14 +19,16 @@ pkgver() {
git describe --long | sed 's/v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
+build() {
+ python setup.py build
+}
+
check() {
- cd xandikos
- python setup.py test
+ python -m unittest xandikos.tests.test_suite
}
package() {
- cd xandikos
- python setup.py install --root="$pkgdir" --optimize=1
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
install -Dm644 xandikos.1 "$pkgdir"/usr/share/man/man1/xandikos.1
}