summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authornikp1232018-03-25 12:56:30 +0200
committernikp1232018-03-25 12:56:30 +0200
commit673119ffed86c0407fe1ced6c1c640f666547b06 (patch)
tree493261865755aea6f4b7eb8b391e42efdb695b11 /PKGBUILD
parent9b714e770a59ebce9ad822f640e41a3d3ae7be6f (diff)
downloadaur-673119ffed86c0407fe1ced6c1c640f666547b06.tar.gz
updated PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 234613c18f14..45d126b561ff 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,23 @@
pkgname=cava-gui-git
_pkgname=cava
-pkgver=0.6.0
-pkgrel=4
+pkgver=VERSION
+pkgrel=1
pkgdesc='Console/GUI Audio Visualizer for Alsa/Pulseaudio'
arch=('i686' 'x86_64')
url='https://github.com/nikp123/cava-gui'
license=('MIT')
-depends=('fftw' 'alsa-lib' 'iniparser' 'ncurses' 'libx11' 'sdl2')
+depends=('fftw' 'alsa-lib' 'iniparser' 'ncurses' 'libx11' 'sdl2' 'portaudio')
makedepends=('libtool' 'automake' 'git')
source=('git+https://github.com/nikp123/cava')
conflicts=($_pkgname)
provides=($_pkgname)
sha1sums=('SKIP')
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
build() {
cd $_pkgname
./autogen.sh