summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2018-11-09 18:56:00 +0000
committerDaniel Bermond2018-11-09 18:56:00 +0000
commit212ecb841fde2d0c65b00fadf3312ae434f53e9d (patch)
tree6a5406f08567b8ec75dd7953494bfa4911f23637 /PKGBUILD
parentc8f9f2c7666abf4f10d738f7271d89bf82127991 (diff)
downloadaur-212ecb841fde2d0c65b00fadf3312ae434f53e9d.tar.gz
Remove 10bit template
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD61
1 files changed, 8 insertions, 53 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 25004a1ce670..e4e34592704f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,20 +6,18 @@
pkgname=xavs2
pkgver=1.0
-pkgrel=3
+pkgrel=4
arch=('i686' 'x86_64')
pkgdesc='Open-Source encoder of AVS2-P2/IEEE1857.4 video coding standard'
url='https://github.com/pkuvcl/xavs2/'
license=('GPL')
depends=('glibc' 'liblsmash.so')
makedepends=('gcc7' 'yasm' 'l-smash')
-provides=('libxavs2' 'libxavs2.so')
+provides=('libxavs2')
conflicts=('libxavs2')
replaces=('libxavs2')
-source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/pkuvcl/${pkgname}/archive/${pkgver}.tar.gz"
- 'xavs2-1.0-disable-10bit.patch')
-sha256sums=('0e7f682ad20dc783864ff0c483d03b2fbcd70d2fbd098e18c8d06ab6341da71d'
- 'e4893da3e1f22e85f8a8f50e58ecaff037d729a3ed64b71794aab6f359c0370c')
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/pkuvcl/${pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=('0e7f682ad20dc783864ff0c483d03b2fbcd70d2fbd098e18c8d06ab6341da71d')
prepare() {
cd "${pkgname}-${pkgver}"
@@ -27,18 +25,14 @@ prepare() {
# use gcc7 (it does not build with gcc8)
sed -i 's/gcc/gcc-7/' build/linux/configure
- # disable 10-bit in configure to avoid misleading errors
- patch -Np1 -i "${srcdir}/xavs2-1.0-disable-10bit.patch"
-
- # must copy the entire source tree for each build or it will not work
+ # must copy the entire source tree or it will not work
cd "$srcdir"
cp -af "${pkgname}-${pkgver}" build-8bit
- cp -af "${pkgname}-${pkgver}" build-10bit
}
build() {
- printf '%s\n' ' -> Building for 8-bit...'
cd build-8bit/build/linux
+
./configure \
--prefix='/usr' \
--enable-shared \
@@ -50,49 +44,10 @@ build() {
--disable-lavf \
--disable-ffms \
--disable-gpac
+
make
-
- printf '%s\n' ' -> Building for 10-bit...'
- cd "${srcdir}/build-10bit/build/linux"
- if ./configure \
- --prefix='/usr' \
- --libdir='/usr/lib/xavs2-10bit' \
- --includedir='/usr/include/xavs2-10bit' \
- --enable-shared \
- --bit-depth='10' \
- --chroma-format='all' \
- --enable-lto \
- --enable-pic \
- --disable-swscale \
- --disable-lavf \
- --disable-ffms \
- --disable-gpac
- then
- make
- else
- cd "$srcdir"
- rm -rf build-10bit
- fi
}
package() {
- local _depth
-
- for _depth in 10 8
- do
- printf '%s\n' " -> Installing for ${_depth}-bit..."
-
- if [ "$_depth" -eq '10' ] && ! [ -d 'build-10bit' ]
- then
- printf '%s\n' 'BitDepth 10 not supported currently.'
- continue
- fi
-
- make -C "build-${_depth}bit/build/linux" DESTDIR="$pkgdir" install-cli install-lib-shared
-
- if [ "$_depth" -eq '10' ]
- then
- mv "${pkgdir}/usr/bin/xavs2" "${pkgdir}/usr/bin/xavs2-${_depth}bit"
- fi
- done
+ make -C build-8bit/build/linux DESTDIR="$pkgdir" install-cli install-lib-shared
}