summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2018-11-21 16:04:03 +0000
committerDaniel Bermond2018-11-21 16:40:54 +0000
commitf87e820514e12891648fdf05d59ec0758ca27be0 (patch)
tree3d741da01d4fb000764e4da1f5f03de81f274fb2 /PKGBUILD
parentf9f4d70cb9211ea71f0bb0aee937168b27e4fea7 (diff)
downloadaur-f87e820514e12891648fdf05d59ec0758ca27be0.tar.gz
Use gcc current to build (fixed upstream)
Build was failing when using gcc8. This problem was fixed upstream. References ---------- https://github.com/pkuvcl/xavs2/issues/17 https://github.com/pkuvcl/xavs2/commit/f018e1da10196c1f03ed8834d5db64ef67f3cc71
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7a79e5f27602..6755dab280b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=xavs2
pkgver=1.2
-pkgrel=1
+pkgrel=2
arch=('i686' 'x86_64')
pkgdesc='Open-Source encoder of AVS2-P2/IEEE1857.4 video coding standard'
url='https://github.com/pkuvcl/xavs2/'
@@ -16,14 +16,15 @@ makedepends=('gcc7' 'yasm' 'l-smash')
provides=('libxavs2')
conflicts=('libxavs2')
replaces=('libxavs2')
-source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/pkuvcl/${pkgname}/archive/${pkgver}.tar.gz")
-sha256sums=('8b985aeb4d5f60b5d8bc9a5e3897f2f4c5ed6546d48f06f87828ee12f6125a5f')
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/pkuvcl/${pkgname}/archive/${pkgver}.tar.gz"
+ 'xavs2-1.2-gcc8-fix.patch')
+sha256sums=('8b985aeb4d5f60b5d8bc9a5e3897f2f4c5ed6546d48f06f87828ee12f6125a5f'
+ '5de344631d212d2d256d9bcad05e4fd7a08701ed6e0017460fa86e6d23a1e25b')
prepare() {
cd "${pkgname}-${pkgver}"
- # use gcc7 (it does not build with gcc8)
- sed -i 's/gcc/gcc-7/' build/linux/configure
+ patch --binary -Np1 -i "${srcdir}/xavs2-1.2-gcc8-fix.patch"
}
build() {