summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2018-11-17 12:18:29 +0000
committerDaniel Bermond2018-11-17 12:18:29 +0000
commitf9f4d70cb9211ea71f0bb0aee937168b27e4fea7 (patch)
treec92e1d0e369504f855b91701579b784c3a3d5fc5 /PKGBUILD
parent212ecb841fde2d0c65b00fadf3312ae434f53e9d (diff)
downloadaur-f9f4d70cb9211ea71f0bb0aee937168b27e4fea7.tar.gz
Updated to version 1.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 5 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e4e34592704f..7a79e5f27602 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
# https://github.com/pkuvcl/xavs2/issues/9
pkgname=xavs2
-pkgver=1.0
-pkgrel=4
+pkgver=1.2
+pkgrel=1
arch=('i686' 'x86_64')
pkgdesc='Open-Source encoder of AVS2-P2/IEEE1857.4 video coding standard'
url='https://github.com/pkuvcl/xavs2/'
@@ -17,21 +17,17 @@ provides=('libxavs2')
conflicts=('libxavs2')
replaces=('libxavs2')
source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/pkuvcl/${pkgname}/archive/${pkgver}.tar.gz")
-sha256sums=('0e7f682ad20dc783864ff0c483d03b2fbcd70d2fbd098e18c8d06ab6341da71d')
+sha256sums=('8b985aeb4d5f60b5d8bc9a5e3897f2f4c5ed6546d48f06f87828ee12f6125a5f')
prepare() {
cd "${pkgname}-${pkgver}"
# use gcc7 (it does not build with gcc8)
sed -i 's/gcc/gcc-7/' build/linux/configure
-
- # must copy the entire source tree or it will not work
- cd "$srcdir"
- cp -af "${pkgname}-${pkgver}" build-8bit
}
build() {
- cd build-8bit/build/linux
+ cd "${pkgname}-${pkgver}/build/linux"
./configure \
--prefix='/usr' \
@@ -49,5 +45,5 @@ build() {
}
package() {
- make -C build-8bit/build/linux DESTDIR="$pkgdir" install-cli install-lib-shared
+ make -C "${pkgname}-${pkgver}/build/linux" DESTDIR="$pkgdir" install-cli install-lib-shared
}