summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2018-11-09 18:55:32 +0000
committerDaniel Bermond2018-11-09 18:55:32 +0000
commitdeb9f82aeef41b88bda47ee856b36d57f745a5b3 (patch)
tree9e76fb0696fdebfaae490d5a88524f0026fd6f2d /PKGBUILD
parent080b11e7080690af1267dcbacbd938b2a98cb124 (diff)
downloadaur-deb9f82aeef41b88bda47ee856b36d57f745a5b3.tar.gz
Remove 10bit template
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD52
1 files changed, 6 insertions, 46 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bb45dedf7452..c32727505a3f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# https://github.com/pkuvcl/xavs2/issues/9
pkgname=xavs2-git
-pkgver=1.0.r135.g1ff3ff8
+pkgver=1.0.r136.gdc1894c
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc='Open-Source encoder of AVS2-P2/IEEE1857.4 video coding standard (git version)'
@@ -13,7 +13,7 @@ url='https://github.com/pkuvcl/xavs2/'
license=('GPL')
depends=('glibc' 'liblsmash.so')
makedepends=('git' 'gcc7' 'yasm' 'l-smash')
-provides=('xavs2' 'libxavs2-git' 'libxavs2.so')
+provides=('xavs2' 'libxavs2-git')
conflicts=('xavs2' 'libxavs2-git')
replaces=('libxavs2-git')
source=("$pkgname"::'git+https://github.com/pkuvcl/xavs2.git')
@@ -25,10 +25,9 @@ prepare() {
# use gcc7 (it does not build with gcc8)
sed -i 's/gcc/gcc-7/' build/linux/configure
- # must copy the entire source tree for each build or it will not work
+ # must copy the entire source tree or it will not work
cd "$srcdir"
cp -af "$pkgname" build-8bit
- cp -af "$pkgname" build-10bit
}
pkgver() {
@@ -39,8 +38,8 @@ pkgver() {
}
build() {
- printf '%s\n' ' -> Building for 8-bit...'
cd build-8bit/build/linux
+
./configure \
--prefix='/usr' \
--enable-shared \
@@ -52,49 +51,10 @@ build() {
--disable-lavf \
--disable-ffms \
--disable-gpac
+
make
-
- printf '%s\n' ' -> Building for 10-bit...'
- cd "${srcdir}/build-10bit/build/linux"
- if ./configure \
- --prefix='/usr' \
- --libdir='/usr/lib/xavs2-10bit' \
- --includedir='/usr/include/xavs2-10bit' \
- --enable-shared \
- --bit-depth='10' \
- --chroma-format='all' \
- --enable-lto \
- --enable-pic \
- --disable-swscale \
- --disable-lavf \
- --disable-ffms \
- --disable-gpac
- then
- make
- else
- cd "$srcdir"
- rm -rf build-10bit
- fi
}
package() {
- local _depth
-
- for _depth in 10 8
- do
- printf '%s\n' " -> Installing for ${_depth}-bit..."
-
- if [ "$_depth" -eq '10' ] && ! [ -d 'build-10bit' ]
- then
- printf '%s\n' 'BitDepth 10 not supported currently.'
- continue
- fi
-
- make -C "build-${_depth}bit/build/linux" DESTDIR="$pkgdir" install-cli install-lib-shared
-
- if [ "$_depth" -eq '10' ]
- then
- mv "${pkgdir}/usr/bin/xavs2" "${pkgdir}/usr/bin/xavs2-${_depth}bit"
- fi
- done
+ make -C build-8bit/build/linux DESTDIR="$pkgdir" install-cli install-lib-shared
}