summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2018-11-09 22:33:47 +0000
committerDaniel Bermond2018-11-09 22:33:47 +0000
commite8327f50e8a6d6fe5188e11f093da2e98fe76ebd (patch)
tree5b3cf3deee31fa61685402ca437666f887624d1f /PKGBUILD
parentdeb9f82aeef41b88bda47ee856b36d57f745a5b3 (diff)
downloadaur-e8327f50e8a6d6fe5188e11f093da2e98fe76ebd.tar.gz
Do not rename the source clone
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c32727505a3f..246a4512e962 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,9 @@
# https://github.com/pkuvcl/xavs2/issues/9
pkgname=xavs2-git
+_srcname=xavs2
pkgver=1.0.r136.gdc1894c
-pkgrel=1
+pkgrel=2
arch=('i686' 'x86_64')
pkgdesc='Open-Source encoder of AVS2-P2/IEEE1857.4 video coding standard (git version)'
url='https://github.com/pkuvcl/xavs2/'
@@ -16,22 +17,22 @@ makedepends=('git' 'gcc7' 'yasm' 'l-smash')
provides=('xavs2' 'libxavs2-git')
conflicts=('xavs2' 'libxavs2-git')
replaces=('libxavs2-git')
-source=("$pkgname"::'git+https://github.com/pkuvcl/xavs2.git')
+source=('git+https://github.com/pkuvcl/xavs2.git')
sha256sums=('SKIP')
prepare() {
- cd "$pkgname"
+ cd "$_srcname"
# use gcc7 (it does not build with gcc8)
sed -i 's/gcc/gcc-7/' build/linux/configure
# must copy the entire source tree or it will not work
cd "$srcdir"
- cp -af "$pkgname" build-8bit
+ cp -af "$_srcname" build-8bit
}
pkgver() {
- cd "$pkgname"
+ cd "$_srcname"
# git, tags available
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'