summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2018-08-17 21:22:23 +0000
committerDaniel Bermond2018-08-17 21:22:23 +0000
commitf6fe3579093c49705bd053e12beba91ef20027ae (patch)
tree36d97dd5b66ea8e4e2163d834ac9bcb16c195c8a /PKGBUILD
parent1a1cea3c5fd845438ff7402dc4340971564170c7 (diff)
downloadaur-f6fe3579093c49705bd053e12beba91ef20027ae.tar.gz
Change to single package providing everything
This will match the latest changes in package x264 from [extra] official repository. Although x264 package is not related to this one, the base source code template and build system are very similar. Being such, x264 package from [extra] serves as a basis for this package. This change simplifies things by eliminating the need of multiple little correlated xavs2 packages, sticking with the Arch KISS principle. References ---------- https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/x264&id=c2411345dd7a39390ce4019cea0bfbdd363feb1d
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD152
1 files changed, 66 insertions, 86 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6a2963faafff..65837561b3b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,120 +1,100 @@
# Maintainer : Daniel Bermond < yahoo-com: danielbermond >
# NOTE:
-# - 10-bit depth currently fails to build
-# - 10-bit sections are commented out until it works
+# 10-bit depth currently fails to build
+# https://github.com/pkuvcl/xavs2/issues/9
-pkgbase=xavs2-git
-pkgname=('xavs2-git' 'libxavs2-git') #'libxavs2-10bit-git' 'libxavs2-all-git')
-pkgver=1.0.r75.gd5c2ec2
+pkgname=xavs2-git
+pkgver=1.0.r79.g81c9d9b
pkgrel=1
arch=('i686' 'x86_64')
+pkgdesc='Open-Source encoder of AVS2-P2/IEEE1857.4 video coding standard (git version)'
url='https://github.com/pkuvcl/xavs2/'
license=('GPL')
-depends=('glibc')
+depends=('glibc' 'liblsmash.so')
makedepends=('git' 'gcc7' 'yasm' 'l-smash')
-source=("$pkgbase"::'git+https://github.com/pkuvcl/xavs2.git')
+provides=('xavs2' 'libxavs2' 'libxavs2-git' 'libxavs2.so')
+conflicts=('xavs2' 'libxavs2' 'libxavs2-git')
+replaces=('libxavs2-git')
+source=("$pkgname"::'git+https://github.com/pkuvcl/xavs2.git')
sha256sums=('SKIP')
prepare() {
- cd "$pkgbase"
+ cd "$pkgname"
# use gcc7 (it does not build with gcc8)
sed -i 's/gcc/gcc-7/' build/linux/configure
-
- # must copy the entire source tree for each build or it will not work
- cd "$srcdir"
- cp -af "$pkgbase" build-8bit
- #cp -af "$pkgbase" build-10bit
}
pkgver() {
- cd "$pkgbase"
+ cd "$pkgname"
# git, tags available
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
}
build() {
- for _depth in 8 #10
- do
- msg2 "Building for ${_depth}-bit..."
-
- cd "build-${_depth}bit/build/linux"
-
- ./configure \
- --prefix='/usr' \
- --enable-shared \
- --bit-depth="$_depth" \
- --chroma-format='all' \
- --enable-lto \
- --enable-pic \
- --disable-swscale \
- --disable-lavf \
- --disable-ffms \
- --disable-gpac
-
- make -j1
-
+ # must copy the entire source tree for each build or it will not work
+ cd "$srcdir"
+ cp -af "$pkgname" build-8bit
+ cp -af "$pkgname" build-10bit
+
+ msg2 'Building for 8-bit...'
+ cd build-8bit/build/linux
+ ./configure \
+ --prefix='/usr' \
+ --enable-shared \
+ --bit-depth='8' \
+ --chroma-format='all' \
+ --enable-lto \
+ --enable-pic \
+ --disable-swscale \
+ --disable-lavf \
+ --disable-ffms \
+ --disable-gpac
+ make
+
+ msg2 'Building for 10-bit...'
+ cd "${srcdir}/build-10bit/build/linux"
+ if ./configure \
+ --prefix='/usr' \
+ --libdir='/usr/lib/xavs2-10bit' \
+ --includedir='/usr/include/xavs2-10bit' \
+ --enable-shared \
+ --bit-depth='10' \
+ --chroma-format='all' \
+ --enable-lto \
+ --enable-pic \
+ --disable-swscale \
+ --disable-lavf \
+ --disable-ffms \
+ --disable-gpac
+ then
+ make
+ else
cd "$srcdir"
- done
+ rm -rf build-10bit
+ fi
}
-package_xavs2-git() {
- pkgdesc='CLI tool for the open-source encoder of AVS2-P2/IEEE1857.4 video coding standard (git version)'
- depends+=('l-smash')
+package() {
+ local _depth
- for _depth in 8 #10
+ for _depth in 10 8
do
- provides+=("xavs2-${_depth}bit-git" "xavs2-${_depth}bit")
- conflicts+=("xavs2-${_depth}bit")
+ msg2 "Installing for ${_depth}-bit..."
- msg2 "Installing CLI for ${_depth}-bit..."
+ if [ "$_depth" -eq '10' ] && ! [ -d 'build-10bit' ]
+ then
+ printf '%s\n' 'BitDepth 10 not supported currently.'
+ continue
+ fi
- make -C "build-${_depth}bit/build/linux" DESTDIR="$pkgdir" install-cli
-
- mv "$pkgdir"/usr/bin/xavs2 "$pkgdir"/usr/bin/xavs2-${_depth}bit
- done
-
- ln -sf xavs2-8bit "${pkgdir}"/usr/bin/xavs2
-}
-
-package_libxavs2-git() {
- pkgdesc='Library for the open-source encoder of AVS2-P2/IEEE1857.4 video coding standard (8bit depth) (git version)'
- provides=('libxavs2-8bit-git' 'libxavs2-8bit' 'libxavs2' 'libxavs2.so')
- conflicts=('libxavs2-8bit' 'libxavs2-10bit' 'libxavs2-10bit-git')
-
- make -C build-8bit/build/linux DESTDIR="$pkgdir" install-lib-shared
-}
-
-# bash block-comment
-:<<'10-bit-pkgs'
-package_libxavs2-10bit-git() {
- pkgdesc='Library for the open-source encoder of AVS2-P2/IEEE1857.4 video coding standard (10bit depth) (git version)'
- provides=('libxavs2-10bit' 'libxavs2' 'libxavs2-git' 'libxavs2.so')
- conflicts=('libxavs2-10bit' 'libxavs2-8bit' 'libxavs2-8bit-git' 'libxavs2-git')
-
- make -C build-8bit/build/linux DESTDIR="$pkgdir" install-lib-shared
-}
-
-package_libxavs2-all-git() {
- pkgdesc="Library for the open-source encoder of AVS2-P2/IEEE1857.4 video coding standard (all depths) (git version)"
-
- local _ver="$(grep '^api=[0-9]*$' "${pkgbase}/version.sh" | awk -F'=' '{ print $2 }')"
-
- install -d "${pkgdir}/usr/lib/xavs2"
-
- for _depth in 8 10
- do
- provides+=("libxavs2-${_depth}bit.so")
-
- make -C build-${_depth}bit/build/linux DESTDIR="$pkgdir" install-lib-shared
-
- mv "${pkgdir}"/usr/lib/libxavs2.so.${_ver} "${pkgdir}"/usr/lib/xavs2/libxavs2-${_depth}bit.so.${_ver}
+ make -C "build-${_depth}bit/build/linux" DESTDIR="$pkgdir" install-cli install-lib-shared
- rm -r "${pkgdir}"/usr/{include,lib/libxavs2.so,lib/pkgconfig}
-
- ln -sfr "${pkgdir}"/usr/lib/xavs2/libxavs2-${_depth}bit.so{.${_ver},}
+ if [ "$_depth" -eq '10' ]
+ then
+ mv "${pkgdir}/usr/bin/xavs2" "${pkgdir}/usr/bin/xavs2-${_depth}bit"
+ fi
done
}
-10-bit-pkgs