summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCkat2018-03-31 23:33:00 +0200
committerCkat2018-03-31 23:33:00 +0200
commit61dc7219b3aeeb576a68119abac690058cbaefa9 (patch)
treeb0cbbcea1ba4c663d457dac6a5be30c7da2543bd /PKGBUILD
downloadaur-xbanish-timeout-git.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..120a6b57103e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Ckat <ckat@teknik.io>
+pkgname="xbanish-timeout-git"
+pkgver=1.5.r4.g0aa1e44
+pkgrel=1
+pkgdesc="Banish the mouse cursor when typing, show it again when the mouse moves. Patched fork with extra features such as timeout, ignorescroll"
+arch=('i686' 'x86_64')
+url="https://github.com/ckath/xbanish-timeout"
+license=('BSD')
+depends=('libxfixes' 'libxi')
+makedepends=('git')
+conflicts=('xbanish')
+provides=('xbanish')
+source=("$pkgname::git+https://github.com/ckath/xbanish-timeout.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g;s/^v//g'
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ install -Dm755 xbanish $pkgdir/usr/bin/xbanish
+ install -Dm644 xbanish.1 $pkgdir/usr/share/man/man1/xbanish.1
+ install -Dm644 README $pkgdir/usr/share/doc/$pkgname/README
+}
+