summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoranthraxx2015-11-01 04:23:13 +0100
committeranthraxx2015-11-01 04:23:13 +0100
commita7f5d5f9e75dcdbbf880ae3fb3f07c5d8f99df3c (patch)
treee13f27e4fbea9f5f3bba9dfa95b11abfa23bc308 /PKGBUILD
parent80d8a9e7fdf8b1adf3a57373b20fb0a9a5a4e7e8 (diff)
downloadaur-a7f5d5f9e75dcdbbf880ae3fb3f07c5d8f99df3c.tar.gz
upgpkg: xboxdrv 0.8.7-1
upstream release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5dbc66b9a8d3..a86612f5fe23 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Kevin MacMartin <prurigro at gmail dot com>
pkgname=xboxdrv
-pkgver=0.8.6
+pkgver=0.8.7
pkgrel=1
pkgdesc="Userspace gamepad driver for Linux"
url="http://pingus.seul.org/~grumbel/xboxdrv"
@@ -12,20 +12,20 @@ license=('GPL3')
depends=('libx11' 'dbus-glib' 'libusbx' 'python2')
makedepends=('scons' 'boost' 'pkg-config' 'libx11' 'dbus-glib' 'libusb')
backup=("etc/default/${pkgname}")
-source=(http://pingus.seul.org/~grumbel/${pkgname}/${pkgname}-linux-${pkgver}.tar.bz2
+source=(${pkgname}-${pkgver}.tar.gz::https://github.com/xboxdrv/${pkgname}/archive/v${pkgver}.tar.gz
${pkgname}.service
${pkgname}.default)
-sha512sums=('1e2067bde131df256381af01aead12441b11498f3f4370127af1721c4ad53423d2fc89b8bbe3fce6e2e2e53e5227f385f11f83796da91fcc88cfbe1c7d1de8a3'
+sha512sums=('7d72d3e55be048ee005ee4c6383eb8620811d949a02005ce6c01b2866e836040392cef0691ce8cfd8402264c071c9088485ab15b47655578206962b4d3fc280a'
'f1094119372512b29c070949606d6ee7ebd119195a717ddac8a60a0c94016b7d82b569283f02e05ad3e5e76227e8437c7072d346b30960d1eb2a4a681894d5d3'
'4f6e9a12b208254e19daba477dd7787147a8b2c8a83007d92f8cfce6212c21ce3306f23a2669080f0e46986ca102ab08c262b42c678caf1a891326b4e2c40b5f')
prepare() {
- cd ${pkgname}-linux-${pkgver}
+ cd ${pkgname}-${pkgver}
sed -r 's|(env python)$|\12|g' -i xboxdrvctl
}
build() {
- cd ${pkgname}-linux-${pkgver}
+ cd ${pkgname}-${pkgver}
scons \
BUILD=custom \
LINKFLAGS="${LDFLAGS}" \
@@ -34,7 +34,7 @@ build() {
}
package() {
- cd ${pkgname}-linux-${pkgver}
+ cd ${pkgname}-${pkgver}
make PREFIX=/usr DESTDIR="${pkgdir}" install
install -Dm 644 "${srcdir}/${pkgname}.service" "${pkgdir}/usr/lib/systemd/system/${pkgname}.service"
install -Dm 644 "${srcdir}/${pkgname}.default" "${pkgdir}/etc/default/${pkgname}"