summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWu Junyu2022-12-23 17:08:21 +0900
committerWu Junyu2022-12-23 17:08:21 +0900
commita9de48605429c5734249ae9347c003b6ee1438af (patch)
tree6a03681037aa64879af59949956e081608dae9f5 /PKGBUILD
parent3504afd54e2c9f2de9f1249c7ec4e272d551cf22 (diff)
downloadaur-xcfun.tar.gz
Fix cmake installation
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 1 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9d5d0ca80e0e..d851a421932e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,12 +18,6 @@ build() {
cd $pkgname-$pkgver
cmake -H. -Bbuild -DCMAKE_INSTALL_PREFIX=$pkgdir/usr -DXCFUN_PYTHON_INTERFACE=ON
cmake --build build -j`getconf _NPROCESSORS_ONLN`
- # cd build
- # cmake -DCMAKE_BUILD_TYPE=RELEASE -DBUILD_SHARED_LIBS=1 \
- # -DXC_MAX_ORDER=3 -DXCFUN_ENABLE_TESTS=0 \
- # -DCMAKE_INSTALL_PREFIX:PATH=/usr \
- # ..
- # make
}
check(){
@@ -34,5 +28,5 @@ check(){
package() {
cd $pkgname-$pkgver
cmake --install build --prefix $pkgdir/usr/
- # make DESTDIR="$pkgdir/" install
+ mv $pkgdir/usr/share/cmake/XCFun $pkgdir/usr/share
}