summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgiga3002019-06-15 19:33:25 +0200
committergiga3002019-06-15 19:33:25 +0200
commitad01b1bd6dcd6fb52f373644023cfe4dfb7029ca (patch)
treec4bb2ed588a06d6d73b37d6ca34f9acf50f6f676 /PKGBUILD
downloadaur-ad01b1bd6dcd6fb52f373644023cfe4dfb7029ca.tar.gz
init commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9062b1288690
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Contributor: giga300 <giga300[at]protonmail[dot]com>
+# Maintainer: giga300 <giga300[at]protonmail[dot]com>
+
+pkgname=xci2nsp-git
+_pkgname=dedbae
+pkgver=1.0.0.1.r1.g87b08da
+pkgrel=1
+pkgdesc='XCI to NSP converter'
+arch=('any')
+url="https://gitlab.com/roothorick/dedbae"
+license=('ISC')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=('git+https://gitlab.com/roothorick/dedbae.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${_pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/${_pkgname}"
+ git submodule update --init
+ make
+}
+
+package() {
+ cd "$srcdir/${_pkgname}"
+ install -Dm755 "$srcdir/${_pkgname}/bin/${pkgname%-git}" "$pkgdir/usr/bin/${pkgname%-git}"
+}