summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authordax2019-05-26 17:30:52 -0500
committerdax2019-05-26 17:30:52 -0500
commit8e2f0ef03cd8325b815932f114fb6040b4889115 (patch)
tree8e7cad2be7961da84995d004ef8d0750b9b61388 /PKGBUILD
downloadaur-8e2f0ef03cd8325b815932f114fb6040b4889115.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..959d2343714f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: dax <dev@dax.moe>
+pkgname=xdcc
+pkgver=0.1.1
+pkgrel=1
+pkgdesc="xdcc file downloader"
+arch=('x86_64')
+url="https://git.sr.ht/~dax/xdcc"
+license=('ISC')
+makedepends=('go' 'scdoc')
+source=("https://git.sr.ht/~dax/$pkgname/archive/$pkgver.tar.gz")
+md5sums=('17da303dd6a17c2339cfbc5b0185efc2')
+
+build() {
+ cd "$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+ install -D -m 0644 LICENSE "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
+ install -D -m 0644 README.md "$pkgdir"/usr/share/doc/"$pkgname"/README.md
+}