summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBrian Bidulock2022-01-29 02:14:13 -0700
committerBrian Bidulock2022-01-29 02:14:13 -0700
commit8b9e54c446e9d7df6f3763a836fa5bb16e3db8d5 (patch)
treecc7945d2d304a774b060b4fff6c54cbd238126e5 /PKGBUILD
parent2cfbbddd284cf180d38d9dc29c43c0ba29d4cdf2 (diff)
downloadaur-xde-ctools-git.tar.gz
uppkg
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5ca6ebca0344..ac59e8df8038 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,25 @@
# Maintainer: Brian Bidulock <bidulock@openss7.org>
pkgname=xde-ctools-git
-pkgver=1.14.r16.gbeec2ee
+_pkgname=xde-ctools
+pkgver=1.15.r1.g301c9dd
pkgrel=1
pkgdesc="X Desktop Environment C-language tools"
groups=('xde-git')
arch=('i686' 'x86_64')
-url="https://github.com/bbidulock/xde-ctools"
+url="https://github.com/bbidulock/$_pkgname"
license=('GPL')
-provides=('xde-ctools')
-conflicts=('xde-ctools')
+provides=("${_pkgname}=${pkgver%%.r*}-${pkgrel}")
+conflicts=("${_pkgname}")
depends=('libxss' 'libwnck+-git' 'libcanberra')
makedepends=('dbus-glib' 'libunique' 'git' 'xorgproto' 'libnotify' 'gdk-pixbuf-xlib')
optdepends=('xdg-launch-git: launch with recent update and launch notification')
-source=("$pkgname::git+https://github.com/bbidulock/xde-ctools.git")
+source=("$pkgname::git+https://github.com/bbidulock/$_pkgname.git")
md5sums=('SKIP')
pkgver() {
cd $pkgname
- git describe --long --tags | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+ git describe --long --tags | sed -E 's,^[^0-9]*,,;s,([^-]*-g),r\1,;s,-,.,g'
}
prepare() {
@@ -31,11 +32,10 @@ build() {
# gtk2 is using deprecated glib2 declarations
./configure CFLAGS="-Wno-deprecated-declarations $CFLAGS"
# Fight unused direct deps
- sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0 /g' -e 's/ if test "$export_dynamic" = yes && test -n "$export_dynamic_flag_spec"; then/ func_append compile_command " -Wl,-O1,--as-needed"\n func_append finalize_command " -Wl,-O1,--as-needed"\n\0/' libtool
+ sed -i -e "s| -shared | $LDFLAGS\0 |g" -e "s| if test \"\$export_dynamic\" = yes && test -n \"\$export_dynamic_flag_spec\"; then| func_append compile_command \" $LDFLAGS\"\n func_append finalize_command \" $LDFLAGS\"\n\0|" libtool
make CFLAGS="-Wno-deprecated-declarations $CFLAGS"
}
package() {
- cd $pkgname
- make DESTDIR="$pkgdir" install
+ make -C $pkgname DESTDIR="$pkgdir" install
}