summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBrian Bidulock2020-02-11 08:58:19 -0700
committerBrian Bidulock2020-02-11 08:58:19 -0700
commit127b6f8f4c683fd0b3554d68405d2ebb8eb72a26 (patch)
tree957a53fc4db69caef6b3b59d582c5000bbee3c88 /PKGBUILD
parent0c6e9732a6cf4f09654ae7c25a158f616f7f0924 (diff)
downloadaur-127b6f8f4c683fd0b3554d68405d2ebb8eb72a26.tar.gz
uppkg
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c588b41291e2..19591b1d78c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Brian Bidulock <bidulock@openss7.org>
pkgname=xde-session
-pkgver=1.10
-pkgrel=2
+pkgver=1.11
+pkgrel=1
pkgdesc="X Desktop Environment Display and Session Management"
groups=('xde')
arch=('i686' 'x86_64')
@@ -13,12 +13,15 @@ depends=('m4' 'libunique' 'libxvnc' 'xde-theme' 'xde-ctools'
makedepends=('xorgproto')
optdepends=('xorg-xdm-xlogin-git: to use xde-xlogin and xde-xchooser')
source=("https://github.com/bbidulock/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.lz")
-sha256sums=('bbaa094f5bb9462082f3157985aacf802d8e74984678c493558a24e979906b44')
+sha256sums=('ef1354f668b01479d3aec5f88a6821d0b9665702683603804854fa933dc60bf6')
build() {
cd $pkgname-$pkgver
- ./configure
- make
+ # gtk2 is using deprecated glib2 declarations
+ ./configure CFLAGS="-Wno-deprecated-declarations $CFLAGS"
+ # Fight unused direct deps
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0 /g' -e 's/ if test "$export_dynamic" = yes && test -n "$export_dynamic_flag_spec"; then/ func_append compile_command " -Wl,-O1,--as-needed"\n func_append finalize_command " -Wl,-O1,--as-needed"\n\0/' libtool
+ make CFLAGS="-Wno-deprecated-declarations $CFLAGS"
}
package() {