summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBrian Bidulock2019-09-05 15:02:16 -0600
committerBrian Bidulock2019-09-05 15:02:16 -0600
commit302b78609a0904e36965b46b7362dfacb0eec5d4 (patch)
tree2e806adafebca37a328f63858214e88edc7050c9 /PKGBUILD
parentac43aa3577157bb220710c1dec327700f2e0b89a (diff)
downloadaur-302b78609a0904e36965b46b7362dfacb0eec5d4.tar.gz
uppkg
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 10 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 59d0eb63ec78..c57b5324ea8b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,27 @@
# Maintainer: Brian Bidulock <bidulock@openss7.org>
+
pkgname=xde-theme
-pkgver=1.2.26
+pkgver=1.3
pkgrel=1
pkgdesc="Theme and style setting utilities for the X Desktop Environment (XDE)"
-groups=('xde')
arch=('i686' 'x86_64')
-license=('GPL3')
url="http://github.com/bbidulock/xde-theme"
+groups=('xde')
+license=('GPL3')
depends=('libxinerama' 'gdk-pixbuf2' 'libxrandr' 'libsm' 'imlib2')
optdepends=('xde-styles: for styles that work with xde-style')
-makedepends=('git')
-source=("$pkgname::git://github.com/bbidulock/$pkgname.git")
-md5sums=('SKIP')
-
-pkgver() {
- cd $pkgname
- git describe --long --tags | sed 's|-|.|g;s|[.]g[a-f0-9]*$||'
-}
-
-prepare() {
- cd $pkgname
- ./autogen.sh
-}
+source=("https://github.com/bbidulock/${pkgname}/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.lz")
+sha256sums=('55564c9ca5d11d7b4843e1a75cb576f65b91f4e9a99672accebed6fd1b42ae10')
build() {
- cd $pkgname
- ./configure --prefix=/usr --sysconfdir=/etc
- make V=0
+ cd $pkgname-$pkgver
+ ./configure
+ make
}
package() {
- cd $pkgname
+ cd $pkgname-$pkgver
make DESTDIR="$pkgdir" install
}
# vim: et sw=2:
-