summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorThatOneCalculator2023-10-19 18:03:06 -0700
committerThatOneCalculator2023-10-19 18:03:06 -0700
commit8e9a58f151b4931146d66b02ce032b80a7bb092d (patch)
treeec9d4fe8cbd4a8cf741343ccbd52a99c0350c15d /PKGBUILD
parentb35f6aab1f11ab2736e50758fd0da3a0a8eb18b8 (diff)
downloadaur-8e9a58f151b4931146d66b02ce032b80a7bb092d.tar.gz
fix flagged issues
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3e726f39ebd8..fc312601a5f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
_pkgname="xdg-desktop-portal-hyprland"
pkgname="${_pkgname}-git"
-pkgver=r261.e1f145d
-pkgrel=4
+pkgver=r321.d8daa2a
+pkgrel=1
epoch=1
pkgdesc="xdg-desktop-portal backend for hyprland"
url="https://github.com/hyprwm/xdg-desktop-portal-hyprland"
@@ -12,8 +12,8 @@ arch=(x86_64)
license=(custom:MIT)
provides=("${pkgname%-git}" "xdg-desktop-portal-impl" "xdg-desktop-portal-wlr")
conflicts=("${pkgname%-git}" "xdg-desktop-portal-wlr")
-depends=(xdg-desktop-portal pipewire libinih qt6-base qt6-wayland)
-makedepends=(git meson wayland-protocols wayland scdoc cmake)
+depends=(pipewire libinih qt6-base qt6-wayland)
+makedepends=(git meson wayland-protocols wayland scdoc cmake sdbus-cpp)
optdepends=(
"grim: required for the screenshot portal to function"
"slurp: support for interactive mode for the screenshot portal; one of the built-in chooser options for the screencast portal"
@@ -42,6 +42,7 @@ build() {
}
package() {
+ depends=(xdg-desktop-portal)
cd "${srcdir}/${_pkgname}"
DESTDIR="${pkgdir}" ninja -C build install
install -Dm755 hyprland-share-picker/build/hyprland-share-picker -t "${pkgdir}/usr/bin"