summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNicholas Boyd Isacsson2023-04-23 19:37:05 +0200
committerNicholas Boyd Isacsson2023-04-23 19:37:05 +0200
commit4f5c6d69646ac9711c928983a01ebce1fde7d78e (patch)
treed985e3a507a70490e44fce670909d530466b0e34 /PKGBUILD
parent3f6f98e28ebd99c0b6e2203966496c5184c5174a (diff)
downloadaur-4f5c6d69646ac9711c928983a01ebce1fde7d78e.tar.gz
Remove custom patch as no longer necessary
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 4 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index af685cc8af6e..df6210f7d778 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=xdg-ninja-git
_pkgname=xdg-ninja
-pkgver=r193.8395f1b
+pkgver=r324.619f172
pkgrel=1
pkgdesc='A shell script which checks your $HOME for unwanted files and directories.'
arch=('any')
@@ -23,16 +23,10 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
- cd "$srcdir/$_pkgname"
- sed 's/"$(realpath "$0" | xargs dirname)"/\/var\/lib\/xdg-ninja/w replaced.txt' $_pkgname.sh > $_pkgname-patched.sh
- test -s replaced.txt || (echo 'Patch failed, please report out-of-date on AUR' && return 1)
-}
-
package() {
cd "$srcdir/$_pkgname"
- install -vDm 755 $_pkgname-patched.sh "$pkgdir/usr/bin/$_pkgname"
- mkdir -p "$pkgdir/var/lib/$_pkgname/"
- cp -r programs/ "$pkgdir/var/lib/$_pkgname/"
+ install -vDm 755 $_pkgname.sh "$pkgdir/usr/bin/$_pkgname"
+ mkdir -p "$pkgdir/usr/share/$_pkgname/"
+ cp -r programs/ "$pkgdir/usr/share/$_pkgname/"
}