summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFrancesco Cherchi2021-12-05 15:45:43 +0100
committerFrancesco Cherchi2021-12-05 15:45:43 +0100
commitab91d250562fc985867fa5b86153dcacef2bf9bb (patch)
treecd5e4c01965067ad7fc00637b50b113b95b04bd7 /PKGBUILD
downloadaur-xdgmenumaker-git.tar.gz
add package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..29c58863e7f2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Francesco Cherchi <francesco.cherchi@protonmail.com>
+# Contributor: Francesco Cherchi <francesco.cherchi@protonmail.com>
+
+pkgname=xdgmenumaker-git
+pkgver=r204.7dd8a63
+pkgrel=2
+pkgdesc="A command line tool that generates XDG menus for several window managers"
+url="https://github.com/gapan/${pkgname%-git}"
+arch=('any')
+license=('GPL3')
+depends=('python-pyxdg' 'python-gobject' 'gtk3')
+makedepends=('git')
+optdepends=('txt2tags: for manpages' 'python-pillow: for restricting icon size')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("git+${url}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${pkgname%-git}"
+ make
+}
+
+package() {
+ cd "${pkgname%-git}"
+ make DESTDIR="$pkgdir/" PREFIX="/usr" install
+}
+