summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Wagner2015-06-14 09:38:39 -0400
committerAndreas Wagner2015-06-14 09:38:39 -0400
commit592226bf202f64265ad7b14fe42bf0a6e4fc7684 (patch)
tree66a99c18369cf6c1da742ff3d0e64da64453429a /PKGBUILD
downloadaur-592226bf202f64265ad7b14fe42bf0a6e4fc7684.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9ce9f96f3094
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Andreas B. Wagner <andreas.wagner@lowfatcomputing.org>
+_pkgname=xdotool
+pkgname=${_pkgname}-git
+pkgver=0.r512.f5309ec
+pkgrel=1
+pkgdesc="Command-line X11 automation tool"
+arch=('i686' 'x86_64')
+url="http://www.semicomplete.com/projects/xdotool"
+license=('BSD')
+depends=('libxkbcommon' 'libxinerama' 'libxtst')
+makedepends=('git')
+provides=($_pkgname)
+conflicts=($_pkgname)
+replaces=(${_pkgname}-svn)
+source=("$pkgname::git+https://github.com/jordansissel/${_pkgname}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ printf "0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ find $srcdir/$pkgname -type f -exec sed -i 's/\r//g' {} \;
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ export PATH=$PATH:/usr/bin/core_perl/ make PREFIX="$pkgdir/usr" INSTALLMAN="$pkgdir/usr/share/man"
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ make PREFIX="$pkgdir/usr" INSTALLMAN="$pkgdir/usr/share/man" install
+ install -Dm644 COPYRIGHT "$pkgdir/usr/share/licenses/$_pkgname/COPYRIGHT"
+}