summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2018-10-27 00:18:22 +0000
committerDaniel Bermond2018-10-27 00:18:22 +0000
commita5f83a8c94292c5d5968a0c216db50272461bc16 (patch)
treeb3e7817f3f2d704c53f2c4ba782209653b08b891 /PKGBUILD
parent339b5d0d0e9dc3e441f275e4f43ac540fd06944e (diff)
downloadaur-a5f83a8c94292c5d5968a0c216db50272461bc16.tar.gz
Fixes
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9bbcbf91058f..5353433c9958 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
-# Maintainer : Daniel Bermond < yahoo-com: danielbermond >
+# Maintainer : Daniel Bermond < gmail-com: danielbermond >
# Contributor: Andreas B. Wagner <andreas.wagner@lowfatcomputing.org>
pkgname=xdotool-git
-pkgver=3.20160805.1.r21.g1334329
+pkgver=3.20160805.1.r23.g08c8e2d
pkgrel=1
pkgdesc='Command-line X11 automation tool (git version)'
arch=('i686' 'x86_64')
@@ -11,18 +11,20 @@ license=('BSD')
depends=('libxtst' 'libxinerama' 'libxkbcommon')
makedepends=('git')
provides=('xdotool' 'libxdo.so')
-conflicts=('xdotool')
+conflicts=('xdotool' 'xdotool-svn')
replaces=('xdotool-svn')
source=("$pkgname"::'git+https://github.com/jordansissel/xdotool.git')
md5sums=('SKIP')
pkgver() {
cd "$pkgname"
+
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
}
build() {
cd "$pkgname"
+
make WITHOUT_RPATH_FIX='1'
}
@@ -31,7 +33,7 @@ package() {
make PREFIX='/usr' INSTALLMAN='/usr/share/man' DESTDIR="$pkgdir" install
# remove execute bit from header file
- chmod -x "${pkgdir}/usr/include/xdo.h"
+ chmod a-x "${pkgdir}/usr/include/xdo.h"
install -D -m644 COPYRIGHT "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}