summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexandre Bouvier2021-01-04 22:03:18 +0100
committerAlexandre Bouvier2021-01-04 22:07:42 +0100
commit4f08c43a0f16a5f78bf73e234e989c780fdc521d (patch)
treeb71c735776babd3c02cad64c3f31a356f05449d5 /PKGBUILD
parent4bb119ad5cf9555906cde01a04d3e7ecfdf9ab20 (diff)
downloadaur-4f08c43a0f16a5f78bf73e234e989c780fdc521d.tar.gz
0.5.0.r2.g270310e603
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2541f538b7bd..9dab5a6322c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
# shellcheck shell=bash disable=SC2034,SC2164
_pkgname=xemu
pkgname=$_pkgname-git
-pkgver=0.3.0.r2.gfcd3764cce
+pkgver=0.5.0.r2.g270310e603
pkgrel=1
pkgdesc="Original Xbox emulator (fork of XQEMU)"
arch=('x86_64')
url="https://xemu.app/"
license=('GPL2')
-depends=('sdl2' 'libepoxy' 'pixman' 'gtk3' 'glu')
+depends=('glu' 'gtk3' 'libsamplerate' 'sdl2')
makedepends=('git' 'python')
provides=("$_pkgname")
conflicts=("$_pkgname")
@@ -28,8 +28,8 @@ build() {
package() {
cd $_pkgname
# shellcheck disable=SC2154
- install -Dm755 i386-softmmu/qemu-system-i386 "$pkgdir"/usr/bin/$_pkgname
- install -Dm644 -t "$pkgdir"/usr/share/$_pkgname/data data/*
- install -Dm644 ui/xemu.desktop "$pkgdir"/usr/share/applications/$_pkgname.desktop
- install -Dm644 ui/icons/xemu.svg "$pkgdir"/usr/share/icons/hicolor/scalable/apps/$_pkgname.svg
+ install -Dm755 -t "$pkgdir"/usr/bin dist/xemu
+ install -Dm644 -t "$pkgdir"/usr/share/$_pkgname/data dist/data/*
+ install -Dm644 -t "$pkgdir"/usr/share/applications ui/xemu.desktop
+ install -Dm644 -t "$pkgdir"/usr/share/icons/hicolor/scalable/apps ui/icons/xemu.svg
}