summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMaik Broemme2018-05-15 11:44:54 +0200
committerMaik Broemme2018-05-15 11:44:54 +0200
commit6bd2585e6755aeade6f2794fa7c1504132bb5188 (patch)
tree89b0f6227914294d930bba41be5c2051aa205d89 /PKGBUILD
parent20f9397209d78a315d4fb065df3c7900a7c62993 (diff)
downloadaur-6bd2585e6755aeade6f2794fa7c1504132bb5188.tar.gz
Update to 4.10.1, fixed compilation issue with gcc-8
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD62
1 files changed, 39 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b79367767fe1..74de456379eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,8 +12,8 @@ _build_stubdom=${build_stubdom:-false}
pkgbase="xen"
pkgname=("xen" "xen-docs")
-pkgver="4.10.0"
-pkgrel="6"
+pkgver="4.10.1"
+pkgrel="2"
arch=("x86_64") # TODO What about ARM?
url="http://www.xenproject.org/"
license=("GPL2")
@@ -65,11 +65,6 @@ source=(
"ipxe-git.tar.gz::http://xenbits.xen.org/xen-extfiles/ipxe-git-356f6c1b64d7a97746d1816cef8ca22bdd8d0b5d.tar.gz"
# XSA patches.
- "xsa253-xsa254-diff-release410-comet1.1.patch::https://xenbits.xen.org/gitweb/?p=xen.git;a=commitdiff_plain;hp=refs/tags/RELEASE-4.10.0;h=refs/heads/4.10.0-shim-comet"
- "https://xenbits.xen.org/xsa/xsa255-1.patch"
- "https://xenbits.xen.org/xsa/xsa255-2.patch"
- "https://xenbits.xen.org/xsa/xsa256.patch"
- "https://xenbits.xen.org/xsa/xsa258.patch"
# Helper and config files.
"grub-mkconfig-helper"
@@ -81,18 +76,22 @@ source=(
# Compile fixes.
"ocaml-unsafe-string.patch"
"qemu-xen-memfd.patch::https://github.com/qemu/qemu/commit/75e5b70e6b5dcc4f2219992d7cffa462aa406af0.patch"
+ "xen-gcc-8-libxc-fix-strncpy-size.patch::https://xenbits.xen.org/gitweb/?p=xen.git;a=patch;h=fa7789ef18bd2e716997937af71b2e4b5b00a159"
+ "xen-gcc-8-misc-fix-hypothetical-buffer-overflow-in-xen-lowmemd.patch::https://xenbits.xen.org/gitweb/?p=xen.git;a=patch;h=27751d89248c8c5eef6d8b56eb8f7d2084145080"
+ "xen-gcc-8-fix-possible-null-truncation.patch::https://xenbits.xen.org/gitweb/?p=xen.git;a=patch;h=938c8f53b1f80175c6f7a1399efdb984abb0cb8b"
+ "xen-gcc-8-gdbsx-fix-wstringop-truncation-warning.patch::https://xenbits.xen.org/gitweb/?p=xen.git;a=patch;h=7f601f7c341c80d554615556d60e3b8ed1e5ad4f"
+ "xen-gcc-8-blktap2-fix-possible-null-truncation.patch::https://xenbits.xen.org/gitweb/?p=xen.git;a=patch;h=850e89b3ef1a7be6b71fa7ae22333c884e08431a"
+ "xen-gcc-8-blktap2-fix-hypothetical-buffer-overflow.patch::https://xenbits.xen.org/gitweb/?p=xen.git;a=patch;h=3a633c261426f06627d88bf7feca6ff87f692f16"
+ "xen-gcc-8-kdd-mute-spurious-gcc-warning.patch::https://xenbits.xen.org/gitweb/?p=xen.git;a=patch;h=437e00fea04becc91c1b6bc1c0baa636b067a5cc"
+ "xen-gcc-8-tools-fix-format-truncation-warnings.patch"
+ "ipxe-git-use-no-pie-on-newer-versions-of-gcc.patch::https://git.ipxe.org/ipxe.git/patch/7c395b0e21806b946fe944a27fc273407f357ea1"
)
sha256sums=(
- "0262a7023f8b12bcacfb0b25e69b2a63291f944f7683d54d8f33d4b2ca556844"
+ "570d654f357d4085accdf752989c1cbc33e2075feac8fcc505d68bdb81b1a0cf"
"SKIP"
"251e5516d7de470c434ae5c393aacca2b61fb24d93770592a4a20add60b785c4"
# XSA patches.
- "fa8cd07b85a8ff29cba8d891f12f9be4b173dd91a58404aabbf49c3f83152af9"
- "05a5570ecf4354f7aad35bb77a4c2f5f556bcabf3555829a98c94dcfb6dd4696"
- "df43a147f1e1a2b7d59588bc91cdaac05d4e45bcfc4e2c8cb5e8de840d44b43d"
- "3e45cc3f2ea516e7470083592041e238c0dfe32324790b2fba0e47c9efe38865"
- "7e8014deae4fa19464fe6570d0719f8f0d7730dd153d58b2fa38b0cd5ed2e459"
# Helper and config files.
"23c3b0eab4cb06260bd07324d2060356560c9bc52270aaaf6130e1c130fc6e5e"
@@ -104,6 +103,15 @@ sha256sums=(
# Compile fixes.
"7c76b116ce09a53708306682f04e1460a788fe66f832091b7003a5d8e1fee312"
"29004b3b9f79bb2cdb0553c5a77c8d748a92e628405b7d9f9ae46693515757bb"
+ "fc1a4ce85795a9a00161d5188b61db5054c462db9a65a8073a5b55b49b089e4d"
+ "3fefa746363a0b05e4b90b18f4a510cd1eb10cd4ea2b845fa6099a5622490724"
+ "4e5a7c72ed9b40c9f1f47d2dce3d4501d293bec208cd170ff5702cf9a1fc3a01"
+ "332874f3e83da80c8a53b49e95db2fdd36b94da3ac053089276ae1e34880e585"
+ "591dcf7b3fd48c5532c69ea12d7d1d1c39afa1cc81c8025dcced86b72c35dbf7"
+ "1fc533158855b38d0b44e52865417d883ab7a165d1b22090c351ad683d43a06f"
+ "06d9d454f888eeb18189c22398b67395e410d43a14e91752fa36f367e7e9d81f"
+ "ac929c45e2319c80d6e6bbab6a5a2e4190741892dd32d25bcdd5aa00cfa2f251"
+ "51ff22b2d0f7e9d7a13666adb2c32321e725e9c0bf0f434b3cc7c760d88620c6"
)
noextract=(
"ipxe-git.tar.gz"
@@ -153,16 +161,8 @@ prepare() {
msg2 'Copying downloaded files...'
cp "${srcdir}/ipxe-git.tar.gz" tools/firmware/etherboot/ipxe.tar.gz
- # XSA patches
- msg2 'Applying XSA Patches...'
- patch -Np1 -i "${srcdir}/xsa253-xsa254-diff-release410-comet1.1.patch"
- patch -Np1 -i "${srcdir}/xsa255-1.patch"
- patch -Np1 -i "${srcdir}/xsa255-2.patch"
- patch -Np1 -i "${srcdir}/xsa256.patch"
- patch -Np1 -i "${srcdir}/xsa258.patch"
-
- # XSA 253 and XSA 254 fix to keep version number.
- sed 's,1-pre,0,g' -i xen/Makefile
+ # XSA patches.
+ msg2 'Applying XSA patches...'
# Security patches and compile fixes (qemu-xen-traditional).
msg2 'Applying tools patches (qemu-xen-traditional)...'
@@ -178,6 +178,18 @@ prepare() {
# Misc compile fixes (removed in future versions if not needed anymore).
msg2 'Applying misc compile fixes...'
patch -Np1 -i "${srcdir}/ocaml-unsafe-string.patch"
+ patch -Np1 -i "${srcdir}/xen-gcc-8-libxc-fix-strncpy-size.patch"
+ patch -Np1 -i "${srcdir}/xen-gcc-8-misc-fix-hypothetical-buffer-overflow-in-xen-lowmemd.patch"
+ patch -Np1 -i "${srcdir}/xen-gcc-8-fix-possible-null-truncation.patch"
+ patch -Np1 -i "${srcdir}/xen-gcc-8-gdbsx-fix-wstringop-truncation-warning.patch"
+ patch -Np1 -i "${srcdir}/xen-gcc-8-blktap2-fix-possible-null-truncation.patch"
+ patch -Np1 -i "${srcdir}/xen-gcc-8-blktap2-fix-hypothetical-buffer-overflow.patch"
+ patch -Np1 -i "${srcdir}/xen-gcc-8-kdd-mute-spurious-gcc-warning.patch"
+ patch -Np1 -i "${srcdir}/xen-gcc-8-tools-fix-format-truncation-warnings.patch"
+
+ # Compile fix for ipxe package with gcc-8.
+ cp "${srcdir}/ipxe-git-use-no-pie-on-newer-versions-of-gcc.patch" "${srcdir}/xen-4.10.1/tools/firmware/etherboot/patches"
+ echo "ipxe-git-use-no-pie-on-newer-versions-of-gcc.patch" >> "${srcdir}/xen-4.10.1/tools/firmware/etherboot/patches/series"
# Fix Install Paths.
msg2 'Fixing installation paths...'
@@ -314,6 +326,10 @@ package_xen() {
# Remove syms.
find "${pkgdir}/usr/lib/debug" -type f \( -name '*-syms*' -or -name '*\.map' \) -delete
+ rmdir "${pkgdir}/usr/lib/debug/usr/lib/xen/boot"
+ rmdir "${pkgdir}/usr/lib/debug/usr/lib/xen"
+ rmdir "${pkgdir}/usr/lib/debug/usr/lib"
+ rmdir "${pkgdir}/usr/lib/debug/usr"
rmdir "${pkgdir}/usr/lib/debug"
# Remove SysVinit files.