summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSandy Carter2018-02-19 22:09:40 -0800
committerSandy Carter2018-02-19 22:09:40 -0800
commitf7cc774f08f2936f2e978c6048d5d565a1dff904 (patch)
tree6cb47b62729e0e4b5ec431dbd439b85ccfa4d781 /PKGBUILD
parenta0109c0571d311707bbafd0ba6f1c4ada8cd82bb (diff)
downloadaur-f7cc774f08f2936f2e978c6048d5d565a1dff904.tar.gz
Replace unmodified submodules with packages
Replace Catch2, SIRV-Headers and yaml-cpp
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 3 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a7746624d127..302c6429dee5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,27 +5,24 @@ pkgdesc="Xenia is an experimental emulator for the Xbox 360."
arch=('x86_64')
url="http://xenia.jp"
license=('BSD')
-depends=('gtk3' 'lz4' 'glew' 'libx11' 'libc++')
+depends=('gtk3' 'lz4' 'glew' 'libx11' 'libc++' 'yaml-cpp')
# TODO use installed premake5 instead of building it
# premake: powerpc patch added
-makedepends=('python' 'clang' 'vulkan-headers' 'git' 'clang' 'libpthread-stubs')
+makedepends=('python' 'clang' 'vulkan-headers' 'git' 'clang' 'libpthread-stubs' 'catch2')
provides=('xenia')
conflicts=('xenia')
# TODO: Use system installed deps for non-forked libs
source=("git+https://github.com/benvanik/xenia.git"
"git+https://github.com/benvanik/binutils-ppc-cygwin"
"git+https://github.com/xenia-project/capstone.git"
- "git+https://github.com/catchorg/Catch2" # catch-git
"git+https://github.com/benvanik/gflags.git"
"git+https://github.com/ocornut/imgui.git"
"git+https://github.com/xenia-project/libav.git"
"git+https://github.com/xenia-project/premake-core.git"
"git+https://github.com/xenia-project/premake-export-compile-commands.git"
"git+https://github.com/xenia-project/snappy.git"
- "git+https://github.com/KhronosGroup/SPIRV-Headers" # spirv-headers or glslang
"git+https://github.com/xenia-project/SPIRV-Tools.git"
- "git+https://github.com/xenia-project/xbyak.git"
- "git+https://github.com/jbeder/yaml-cpp.git") # yaml-cpp
+ "git+https://github.com/xenia-project/xbyak.git")
sha256sums=('SKIP'
'SKIP'
'SKIP'
@@ -36,9 +33,6 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
'SKIP')
pkgver() {