summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoseph Riches2015-08-09 10:22:52 +0100
committerJoseph Riches2015-08-09 10:22:52 +0100
commitdb1be152fdb945b41777b2176c12e6583a12442b (patch)
treed2c05c224384221f05435eb16c55c658a4bdbcf2 /PKGBUILD
downloadaur-db1be152fdb945b41777b2176c12e6583a12442b.tar.gz
xf86-input-cmt-setup: initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..720bda3ca6fb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Submitter: Joseph Riches
+
+pkgname=xf86-input-cmt-setup
+pkgdesc="A script to install the correct device specific conf files for the xf86-input-cmt driver"
+pkgver=1
+pkgrel=1
+arch=(any)
+url="https://github.com/joebonrichie/xf86-input-cmt-conf"
+_gitname=("xf86-input-cmt-conf")
+license=('GPLv3')
+provides=("xf86-input-cmt=$pkgver")
+install=${pkgname}.install
+depends=('dmidecode')
+makedepends=('git')
+
+source=("$_gitname::git+https://github.com/joebonrichie/xf86-input-cmt-conf.git")
+md5sums=('SKIP')
+
+package() {
+ cd "$srcdir/$_gitname"
+ mkdir -p $pkgdir/usr/bin/
+ mv cmt-post-install.sh cmt-post-install
+ cp cmt-post-install $pkgdir/usr/bin/cmt-post-install
+}