summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChris Morgan2015-08-11 12:48:29 +1000
committerChris Morgan2015-08-11 12:48:29 +1000
commit2bfb57409b8e1f29265c9b89f62d0f6e8af923cb (patch)
tree95d6017ecd3f314e3fb1f3e56919584ad9c24699 /PKGBUILD
downloadaur-2bfb57409b8e1f29265c9b89f62d0f6e8af923cb.tar.gz
Import from AUR3.
This is functionally exactly what was on AUR3, but I have adjusted whitespace and quotation marks in PKGBUILD trivially, made it download the package via HTTPS (the canonical source) rather than HTTP, and changed the package description to that provided by the project.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..229302019a31
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Contributor: Mihai Militaru <mihai dot militaru at xmpp dot ro>
+
+pkgname=xf86-input-wizardpen
+_realname=xorg-input-wizardpen
+pkgver=0.8.1
+pkgrel=4
+pkgdesc="X.Org Wizardpen/Genius tablet driver for Linux"
+arch=('i686' 'x86_64')
+url="https://launchpad.net/wizardpen"
+license=('GPL2')
+depends=('glibc')
+makedepends=('xorg-server-devel')
+conflicts=('wizardpen-driver wizardpen')
+replaces=('wizardpen-driver wizardpen')
+source=(https://launchpad.net/wizardpen/trunk/0.8/+download/${_realname}-${pkgver}.tar.bz2
+ config.patch)
+sha1sums=('82060c678dc241de83b2b7415b6ada619b94db36'
+ '86ce045389f477d4bb5b3f89fe7bd26ebe80e6db')
+
+build() {
+ cd "$srcdir/$_realname-$pkgver"
+ patch -Np0 -i "$srcdir"/config.patch
+ ./autogen.sh --prefix=/usr --with-xorg-conf-dir=/etc/X11/xorg.conf.d
+ make
+}
+
+package() {
+ cd "$srcdir/$_realname-$pkgver"
+ make DESTDIR="${pkgdir}" install
+}