summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorYurii Kolesnykov2018-07-27 00:12:15 +0300
committerYurii Kolesnykov2018-07-27 00:12:15 +0300
commit181107164a12ddbef8e334b552a1e1f285588740 (patch)
treef00125b08fc4c986e3652664474027a499cb3615 /PKGBUILD
parent4ddb667342f931194dc2f06d2020dabba7c2e32d (diff)
downloadaur-181107164a12ddbef8e334b552a1e1f285588740.tar.gz
v18.0.1.44
port changes from stable package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD48
1 files changed, 34 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 845a040e45ff..75d89b5cbbb9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,41 +3,61 @@
pkgname=xf86-video-amdgpu-git
_pkgbase=xf86-video-amdgpu
-pkgver=18.0.1.r19.g74124f2
+pkgver=18.0.1.44
pkgrel=1
-pkgdesc="X.org amdgpu video driver"
-arch=('i686' 'x86_64')
-url="http://xorg.freedesktop.org/"
+pkgdesc="X.org amdgpu video driver (git version)"
+arch=('x86_64')
+url="https://xorg.freedesktop.org/"
license=('custom')
depends=('libsystemd' 'mesa')
-makedepends=('xorg-server-devel' 'systemd' 'X-ABI-VIDEODRV_VERSION=24.0')
-conflicts=('xf86-video-amdgpu' 'xorg-server<1.19.0' 'X-ABI-VIDEODRV_VERSION<24' 'X-ABI-VIDEODRV_VERSION>=25')
+makedepends=('xorg-server-devel' 'systemd')
+conflicts=('xf86-video-amdgpu' 'xorg-server<1.20.0')
provides=('xf86-video-amdgpu')
groups=('xorg-drivers')
source=('xf86-video-amdgpu::git://anongit.freedesktop.org/xorg/driver/xf86-video-amdgpu#branch=master')
-md5sums=('SKIP')
-validpgpkeys=('B09FAF35BE914521980951145A81AF8E6ADBB200') # Michel Daenzer <michel@daenzer.net>
+sha256sums=('SKIP')
+# pkgver() {
+# cd "${_pkgbase}"
+# ( set -o pipefail
+# git describe --long | sed 's/^xf86-video-amdgpu-//;s/\([^-]*-g\)/r\1/;s/-/./g'
+# )
+# }
pkgver() {
- cd "${_pkgbase}"
- ( set -o pipefail
- git describe --long | sed 's/^xf86-video-amdgpu-//;s/\([^-]*-g\)/r\1/;s/-/./g'
- )
+ local version count
+
+ cd "$_pkgbase"
+
+ version="$(git describe --abbrev=0 --tags)"
+ count="$(git rev-list --count ${version}..)"
+ printf '%s.%s' "${version#v}" "${count}"|sed 's/^xf86-video-amdgpu-//'
}
build() {
cd "${_pkgbase}"
+ # Since pacman 5.0.2-2, hardened flags are now enabled in makepkg.conf
+ # With them, module fail to load with undefined symbol.
+ # See https://bugs.archlinux.org/task/55102 / https://bugs.archlinux.org/task/54845
+ export CFLAGS=${CFLAGS/-fno-plt}
+ export CXXFLAGS=${CXXFLAGS/-fno-plt}
+ export LDFLAGS=${LDFLAGS/,-z,now}
+
./autogen.sh --prefix=/usr \
--enable-glamor
make
}
+check() {
+ cd "${_pkgbase}"
+ make check
+}
+
package() {
cd "${_pkgbase}"
make "DESTDIR=${pkgdir}" install
- install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
- install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/"
+ install -m0755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m0644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/"
}