summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorYurii Kolesnykov2019-06-30 10:03:16 +0300
committerYurii Kolesnykov2019-06-30 10:03:16 +0300
commitf0b2f4100dcdf615b85a8ead5ffeef1976a8fa09 (patch)
treebb816eef94f0e455753745bfb0b7a553e093681c /PKGBUILD
parentf8d3471e2fa2ea4bb255eb2ba8b9317e8bad1de0 (diff)
downloadaur-f0b2f4100dcdf615b85a8ead5ffeef1976a8fa09.tar.gz
Cleanup
Signed-off-by: Yurii Kolesnykov <root@yurikoles.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 23 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 126cded4468b..e21eceaa227e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,48 @@
-# $Id$
-# Maintainer: Andreas Rammhold <andreas@rammhold.de>
+# Maintainer: Yurii Kolesnykov <root@yurikoles.com>
+# Contributor: Andreas Rammhold <andreas@rammhold.de>
+# Contributor: Andreas Radke <andyrtr@archlinux.org>
+# Contributor: buddabrod <buddabrod@gmail.com>
pkgname=xf86-video-nouveau-git
_pkgname=xf86-video-nouveau
-pkgver=1.0.13+7+g1516d35
+pkgver=1.0.16+0+gec2b45d
pkgrel=1
-pkgdesc="Open Source 2D acceleration driver for nVidia cards"
+pkgdesc="Open Source 3D acceleration driver for nVidia cards"
arch=('i686' 'x86_64')
url="http://nouveau.freedesktop.org/"
license=('GPL')
-depends=('libdrm' 'systemd' 'mesa-dri')
-makedepends=('xorg-server-devel' 'git')
-conflicts=('xorg-server<1.19' 'X-ABI-VIDEODRV_VERSION<23' 'X-ABI-VIDEODRV_VERSION>=24', 'xf86-video-nouveau')
-groups=('xorg-drivers' 'xorg')
-install=$pkgname.install
-#source=(http://xorg.freedesktop.org/archive/individual/driver/$pkgname-$pkgver.tar.bz2)
+depends=('systemd-libs' 'mesa')
+makedepends=('xorg-server-devel' 'git' 'systemd')
+conflicts=('xf86-video-nouveau')
+groups=('xorg-drivers')
source=('git://anongit.freedesktop.org/nouveau/xf86-video-nouveau')
sha256sums=('SKIP')
pkgver() {
- cd $_pkgname
+ cd "${_pkgname}"
git describe --long | sed 's/xf86-video-nouveau-//' | sed 's/-/+/g'
}
prepare() {
- cd $_pkgname
+ cd "${_pkgname}"
NOCONFIGURE=1 ./autogen.sh
-
-# mkdir $pkgname-$pkgver
}
build() {
-# cd $pkgname-$pkgver
- cd $_pkgname
+ cd "${_pkgname}"
+
+ # Since pacman 5.0.2-2, hardened flags are now enabled in makepkg.conf
+ # With them, module fail to load with undefined symbol.
+ # See https://bugs.archlinux.org/task/55102 / https://bugs.archlinux.org/task/54845
+ export CFLAGS="${CFLAGS/-fno-plt}"
+ export CXXFLAGS="${CXXFLAGS/-fno-plt}"
+ export LDFLAGS="${LDFLAGS/,-z,now}"
+
./configure --prefix=/usr
make
}
package() {
-# cd $pkgname-$pkgver
- cd $_pkgname
- make DESTDIR="$pkgdir" install
+ cd "${_pkgname}"
+ make DESTDIR="${pkgdir}" install
}