summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMario Finelli2020-05-27 11:50:56 -0400
committerMario Finelli2020-05-27 11:50:56 -0400
commit37b194744e4ade92d7e60912cb4d1e247c1a36b8 (patch)
treefe0593dee70a8d33b04616a4619faffbabebae6e /PKGBUILD
parent277665935e88f553606194b57fbf42719d50739b (diff)
downloadaur-37b194744e4ade92d7e60912cb4d1e247c1a36b8.tar.gz
Update to v3.8
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bcc38b67c460..23e6c728b7b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,24 +3,24 @@
pkgname=xfce-theme-manager
_pkgname=Xfce-Theme-Manager
-pkgver=0.3.8
+pkgver=3.8
pkgrel=1
-pkgdesc="A theme manager allowing easy configuration of themes, window borders, controls, icons and cursors for Xfce."
+pkgdesc="Integrated theme manager for xfce4"
arch=(i686 x86_64)
url="https://github.com/KeithDHedger/Xfce-Theme-Manager"
license=(GPL3)
depends=(gdk-pixbuf2 cairo libxcursor libxfce4ui)
optdepends=('xfce4-composite-editor: A simple GUI to tweak xfwm, can be launched from xfce-theme-manager')
makedepends=(pkg-config)
-source=("https://github.com/KeithDHedger/$_pkgname/archive/$pkgname-${pkgver}.tar.gz")
-sha256sums=('110eea06a36096c0fc8bf2dd9fe03c90e066f42aebd91f71f1159e87dff99b6f')
+source=("https://github.com/KeithDHedger/$_pkgname/archive/v${pkgver}.tar.gz")
+sha256sums=('da4b6b0ea9b9acde30893358ce2c997f298ffc6fac32e84aab6fa141b7bf26eb')
build() {
- cd "$srcdir"/$_pkgname-$pkgname-$pkgver
+ cd "$_pkgname-$pkgver"
./autogen.sh --prefix="$pkgdir"/usr
sed -i \
's#/PREFIX/share/Xfce\\-Theme\\-Manager/scripts#/usr/share/xfce\\-theme\\-manager/scripts#g' \
- "$srcdir"/$_pkgname-$pkgname-$pkgver/$_pkgname/resources/man/*
+ "$srcdir"/$_pkgname-$pkgver/$_pkgname/resources/man/*
sed -i \
's/Name=Xfce-Theme-Manager/Name=Xfce Theme Manager/g;s/^Comment.*/Comment=Control Xfce4 Themes, Icons, Cursors, Wallpapers and more/g' \
$_pkgname/resources/pixmaps/$_pkgname.desktop
@@ -31,7 +31,7 @@ package() {
"$pkgdir"/usr/share/applications \
"$pkgdir"/usr/share/doc/xfce-theme-manager
- cd "$srcdir"/$_pkgname-$pkgname-$pkgver
+ cd "$srcdir/$_pkgname-$pkgver"
make CXXFLAGS="$CXXFLAGS -O3 -Wall `pkg-config --cflags --libs glib-2.0` `pkg-config --cflags --libs gdk-2.0` `pkg-config --cflags --libs gtk+-2.0` `pkg-config --cflags --libs xcursor` `pkg-config --cflags --libs gthread-2.0`" PREFIX="$pkgdir/usr" install
install -m 644 README* "$pkgdir"/usr/share/doc/$pkgname/