summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatt Parnell2016-10-04 20:01:34 -0500
committerMatt Parnell2016-10-04 20:01:34 -0500
commite0081d44c17b4fe45e14ceb77adeec2376a87f0d (patch)
tree5247696c2d1371a9b80e29d8e19442c3b4cc5034 /PKGBUILD
downloadaur-e0081d44c17b4fe45e14ceb77adeec2376a87f0d.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e4c5e32f3d76
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Matt Parnell <parwok@gmail.com>
+# Contributor: Christian Hesse <mail@eworm.de>
+# Contributor: tobias <tobias at archlinux.org>
+# Contributor: Aurelien Foret <orelien@chez.com>
+
+pkgname=xfce4-clipman-plugin-classic
+pkgver=1.2.6
+pkgrel=1
+pkgdesc='A clipboard plugin for the Xfce4 panel. Classic 1.2.6 version (fewer bugs, maintainer thinks)'
+arch=('i686' 'x86_64')
+license=('GPL')
+url='http://goodies.xfce.org/projects/panel-plugins/xfce4-clipman-plugin'
+groups=('xfce4-goodies')
+depends=('xfce4-panel' 'libunique' 'libxtst' 'qrencode')
+conflicts=('xfce4-clipman-plugin' 'xfce4-clipman-plugin-git')
+provides=('xfce4-clipman-plugin')
+makedepends=('xfce4-dev-tools' 'intltool' 'git')
+options=('!libtool')
+install=xfce4-clipman-plugin.install
+source=("git://git.xfce.org/panel-plugins/xfce4-clipman-plugin#tag=${pkgver}")
+sha256sums=('SKIP')
+
+build() {
+ cd xfce4-clipman-plugin/
+
+ ./autogen.sh
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --disable-static \
+ --enable-unique \
+ --enable-maintainer-mode \
+ --disable-debug
+ make
+}
+
+package() {
+ cd xfce4-clipman-plugin/
+
+ make DESTDIR="${pkgdir}" install
+}
+