summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTed Alff2020-01-27 16:15:45 -0500
committerTed Alff2020-01-27 16:15:45 -0500
commit4c0331e3e3df87351e49441cebb3b75d5fac1600 (patch)
treea3d4f7186fe0288b6e5b3131306383a5ba0b4867 /PKGBUILD
parentdec46f1d4e3071742f95f11b293ad5a02fed2dbb (diff)
downloadaur-4c0331e3e3df87351e49441cebb3b75d5fac1600.tar.gz
Split out the prepare function. Change a call to python2 to python.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f7bf90802fa3..9084a63e3ab5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=xfce4-dockbarx-plugin
pkgname=$_pkgname-gtk3-git
epoch=2
-pkgver=r54+92bce50
+pkgver=r55+e3aec3d
pkgrel=1
pkgdesc="Embed DockbarX in the xfce4-panel"
arch=('i686' 'x86_64')
@@ -22,10 +22,13 @@ pkgver() {
printf "r%s+%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-build() {
+prepare() {
cd "${srcdir}/${_pkgname}"
PREFIX=/usr python ./waf configure
- python2 ./waf build
+}
+build() {
+ cd "${srcdir}/${_pkgname}"
+ python ./waf build
}
package() {