summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFrederic Bezies2021-05-10 22:05:41 +0200
committerFrederic Bezies2021-05-10 22:05:41 +0200
commit9725766350baa0216980e13d8cce0736484a13d2 (patch)
tree778aa6ca51333c62763120f4af239109981add90 /PKGBUILD
parent1852ee98d6f5ce4e69aa249eb0a31a42e149d4f3 (diff)
downloadaur-9725766350baa0216980e13d8cce0736484a13d2.tar.gz
May 10th, 2021 update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 9 insertions, 25 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f3a5ccb404b0..a177576c937d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,49 +1,33 @@
-# This is an example PKGBUILD file. Use this as a start to creating your own,
-# and remove these comments. For more information, see 'man PKGBUILD'.
-# NOTE: Please fill out the license field for your package! If it is unknown,
-# then please put 'unknown'.
-
-# The following guidelines are specific to BZR, GIT, HG and SVN packages.
-# Other VCS sources are not natively supported by makepkg yet.
-
-# Maintainer: Kevin Hanselman <kevin.hanselman@gmail.com>
+# Maintainer: Frederic Bezies <fredbezies at gmail dot com>
+# Contributor: Kevin Hanselman <kevin.hanselman@gmail.com>
pkgname=xfce4-genmon-plugin-git
-pkgver=r317.1c5524c
+pkgver=r768.efe2584
pkgrel=1
pkgdesc="plugin that monitors customizable programs stdout for the Xfce4 panel"
-arch=('any')
-url=""
+arch=('x86_64')
license=('LGPL2')
-groups=()
-depends=()
makedepends=('git' 'xfce4-dev-tools')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-replaces=()
-backup=()
-options=()
-install=
-source=('git+git://git.xfce.org/panel-plugins/xfce4-genmon-plugin')
+depends=('xfce4-panel')
+source=('git+https://gitlab.xfce.org/kevinbowen/xfce4-genmon-plugin.git')
noextract=()
md5sums=('SKIP')
-# Please refer to the 'USING VCS SOURCES' section of the PKGBUILD man page for
-# a description of each element in the source array.
-
pkgver() {
- cd "$srcdir/${pkgname%-git}" || exit
+ cd "$srcdir/${pkgname%-git}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd "$srcdir/${pkgname%-git}" || exit
+ cd "$srcdir/${pkgname%-git}"
./autogen.sh
./configure --prefix=/usr
make
}
package() {
- cd "$srcdir/${pkgname%-git}" || exit
+ cd "$srcdir/${pkgname%-git}"
make DESTDIR="$pkgdir/" install
install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}