summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSilvio Knizek2023-11-14 19:28:22 +0100
committerSilvio Knizek2023-11-14 19:28:22 +0100
commitfaec00a73b33badb116c9d81fd9c1421dedefc1e (patch)
tree75dd072a46c9db2abab3ec8cd4db4829233ee0ca /PKGBUILD
parent3842ab958dbf09304e016f2def3e5915199d6c69 (diff)
downloadaur-xfce4-hotcorner-plugin-git.tar.gz
Update to new remote source. Thanks @mhdi
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 6 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 66eef2d51d4b..d5376d788daa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,19 @@
_pkgname=xfce4-hotcorner-plugin
pkgname="${_pkgname}-git"
-pkgver=0.0.2.r1.g996f76a
+pkgver=0.0.4.r8.gfea4b50
pkgrel=1
pkgdesc="Provides an easy way to set up hot corners in the Xfce desktop environment"
arch=('i686' 'x86_64')
license=('GPL2')
-url="https://github.com/brianhsu/xfce4-hotcorner-plugin"
+url="https://github.com/christopherkobayashi/${_pkgname}"
groups=("xfce4")
depends=('xfce4-panel' 'libwnck3')
-makedepends=('cmake' 'xfce4-dev-tools' 'git')
-provides=("${_pgname}")
+makedepends=('xfce4-panel' 'libwnck3' 'libnotify' 'gtk3' 'intltool')
+provides=("${_pkgname}")
conflicts=("${_pkgname}")
install="${_pkgname}.install"
-source=("${_pkgname}::git+https://github.com/brianhsu/${_pkgname}.git")
+source=("${_pkgname}::git+${url}.git")
sha256sums=('SKIP')
pkgver() {
@@ -24,11 +24,10 @@ pkgver() {
build() {
cd "${srcdir}/${_pkgname}"
- cmake -DCMAKE_INSTALL_PREFIX=/usr
+ ./configure --prefix=/usr && make
}
package() {
cd "${srcdir}/${_pkgname}"
make DESTDIR="$pkgdir" install
}
-