summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorConnor Behan2015-06-08 18:24:17 -0400
committerConnor Behan2015-06-08 18:24:17 -0400
commita4c038dd474a3e62f17895e6a9543b9a3d8e4b66 (patch)
tree03887929fb3453da9086a40a3d50744940464979 /PKGBUILD
downloadaur-a4c038dd474a3e62f17895e6a9543b9a3d8e4b66.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..30efed6ba37c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Contributor: Connor Behan <connor.behan@gmail.com>
+
+pkgname=xfce4-mpc-plugin-update
+pkgver=0.4.5
+pkgrel=1
+pkgdesc="Updates the toggle button icon depending on what MPD is doing"
+arch=(i686 x86_64)
+license=('GPL2')
+url="http://goodies.xfce.org/projects/panel-plugins/xfce4-mpc-plugin"
+groups=('xfce4-goodies')
+depends=('xfce4-panel' 'libmpd>=0.16.1')
+makedepends=('pkgconfig' 'intltool')
+replaces=('xfce4-mpc-plugin')
+provides=('xfce4-mpc-plugin')
+options=(!libtool)
+source=(http://archive.xfce.org/src/panel-plugins/xfce4-mpc-plugin/${pkgver%.*}/xfce4-mpc-plugin-${pkgver}.tar.bz2 update.diff)
+
+build() {
+ cd "${srcdir}"/xfce4-mpc-plugin-${pkgver}
+ patch -Np1 -i ../update.diff
+ ./configure --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib \
+ --localstatedir=/var --disable-static
+ make
+}
+
+package() {
+ cd "${srcdir}"/xfce4-mpc-plugin-${pkgver}
+ make DESTDIR="${pkgdir}" install
+}
+
+md5sums=('718e64748e46908a44cd0b96eacbda28'
+ '8019c8201fb32d7659bbb3ea66fdca80')