summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhoton892019-09-06 10:42:02 +0200
committerPhoton892019-09-06 10:42:02 +0200
commitef0ae296fc348d1e9c2cde800b29c754746e6f76 (patch)
treeea1c26db4d4651644ea11c8f791b491eeb284606 /PKGBUILD
parentc2875e3919ad00305d9ceca34dffa88d8daca723 (diff)
downloadaur-ef0ae296fc348d1e9c2cde800b29c754746e6f76.tar.gz
Update to 4.14
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD50
1 files changed, 36 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 35946602bf03..e5e46a3945f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,12 @@
-# Maintainer: Charles Bos <charlesbos1 AT gmail>
+# Maintainer: Michael Kogan <michael dot kogan at gmx dot net>
+# Contributor: Charles Bos <charlesbos1 AT gmail>
# Contributor: Evangelos Foutras <evangelos@foutrelis.com>
# Contributor: tobias <tobias funnychar archlinux.org>
pkgname=xfce4-panel-compiz
_realname=xfce4-panel
-pkgver=4.12.2
-pkgrel=3
+pkgver=4.14.0
+pkgrel=1
pkgdesc="Panel for the Xfce desktop environment with fixes for Compiz"
arch=('i686' 'x86_64')
url="http://www.xfce.org/"
@@ -17,25 +18,46 @@ makedepends=('intltool' 'gtk-doc')
provides=("$_realname=$pkgver")
conflicts=("$_realname")
source=(http://archive.xfce.org/src/xfce/$_realname/${pkgver%.*}/$_realname-$pkgver.tar.bz2
- workspace-pager.patch
button-visibility.patch
- scrolling-viewports.patch)
-sha256sums=('42058abb81b8f87691d3999627447de71c3285bcf055f308aab5cefab2de0ce9'
- '006889db18e8579033db32eeb85257b1f55b7c378881b69a7671d708304f91af'
+ fix-scrolling.patch
+ fix-scrolling2.patch
+ fix-scrolling3.patch
+ pager-dimensions.patch
+ wrap-workspaces.patch)
+sha256sums=('d5f8f3bd7e142139987e5e62cda26135a424baabb5e47aa0c23b4169d0a66ef4'
'556f7ecc22fdf024101d2e8a0416b953efaef48ff4ed649aab97d5b115a94931'
- '8ca306d6fa63e47008223205b6aed887c02ea313fd0db996b40218771c18224e')
+ '023fbeb4caa99dc97d460040f3d507794f3f576dc6cde98d834ba8a8e581f5ee'
+ '2bbcace9c0c25c14fc1180a1064329240867a0b83c1c668aadc8c77f92ee0aab'
+ '5e17300981a6030a2a3d4172b897e7aea0037401c8c9866cc03d82e0629c7fe2'
+ '7055df37c000731057af828ef99ffb7193a18b3f2ab7dee541d79de029995cae'
+ '063f11ddbf695d0f7b819209245e201c8d7420cbf94a6c557593deb2aa061f82')
prepare() {
cd "$srcdir/$_realname-$pkgver"
- # See https://bugzilla.xfce.org/show_bug.cgi?id=11697
- patch -p1 -i "$srcdir/workspace-pager.patch"
-
# See https://bugzilla.xfce.org/show_bug.cgi?id=10908
+ echo "Applying button-visibility.patch:"
patch -p1 -i "$srcdir/button-visibility.patch"
-
- # See https://bugzilla.xfce.org/show_bug.cgi?id=3361
- patch -p1 -i "$srcdir/scrolling-viewports.patch"
+
+ # See https://git.xfce.org/xfce/xfce4-panel/commit/?id=55dc7b400feef0c35fda3e8d3515dada2ced29c4
+ echo "Applying fix-scrolling.patch:"
+ patch -p1 -i "$srcdir/fix-scrolling.patch"
+
+ # See https://bugzilla.xfce.org/show_bug.cgi?id=3361#c28
+ echo "Applying fix-scrolling2.patch:"
+ patch -p1 -i "$srcdir/fix-scrolling2.patch"
+
+ # See https://bugzilla.xfce.org/show_bug.cgi?id=3361#c32
+ echo "Applying fix-scrolling3.patch:"
+ patch -p1 -i "$srcdir/fix-scrolling3.patch"
+
+ # See https://bugzilla.xfce.org/show_bug.cgi?id=3361#c30
+ echo "Applying wrap-workspaces.patch:"
+ patch -p1 -i "$srcdir/wrap-workspaces.patch"
+
+ # See https://bugzilla.xfce.org/show_bug.cgi?id=11697
+ echo "Applying pager-dimensions.patch:"
+ patch -p1 -i "$srcdir/pager-dimensions.patch"
}
build() {