summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCharles Bos2015-11-14 17:59:26 +0000
committerCharles Bos2015-11-14 17:59:26 +0000
commita363f41ef706854fc943457734eb6a2b9a1ebec3 (patch)
treefc02e5a72f9e70ad7a36d1fabb93cd3acd315b3e /PKGBUILD
parent51e6438b036e978411c068532ff625a075d4a129 (diff)
downloadaur-a363f41ef706854fc943457734eb6a2b9a1ebec3.tar.gz
use patch for bug 11939
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 16 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 86a56c1b415c..e408b0fe2d74 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=xfce4-places-plugin
pkgver=1.7.0
-pkgrel=3
+pkgrel=4
pkgdesc="Places menu plugin for the Xfce panel"
arch=('i686' 'x86_64')
url="http://goodies.xfce.org/projects/panel-plugins/xfce4-places-plugin"
@@ -11,27 +11,32 @@ license=('GPL2')
depends=('libnotify' 'xfce4-panel')
makedepends=('intltool')
source=("http://archive.xfce.org/src/panel-plugins/$pkgname/${pkgver%.*}/$pkgname-${pkgver}.tar.bz2"
- "mounts.patch")
+ "mounts.patch"
+ "undefined-symbol.patch")
sha256sums=('4175c614749abbb5bcf6f49c88125fb0dd36db69f4c374df23563907b16e2c3f'
- '0f772f067bff34dd94a473b192494335eb73c4c3d867e4f5bf81828f825d95eb')
+ '0f772f067bff34dd94a473b192494335eb73c4c3d867e4f5bf81828f825d95eb'
+ '459a303dee55f6d723bf43e91fb8eebf209b59ee2e42bd1772e34f7518cf73aa')
prepare() {
cd "$pkgname-$pkgver"
# Show other mounts that are non disks (eg. NFS)
patch -Np1 -i "${srcdir}/mounts.patch"
+
+ # Bug 11939
+ patch -Np1 -i "${srcdir}/undefined-symbol.patch"
}
build() {
cd "$pkgname-$pkgver"
- # add compatibility for inline functions
- CFLAGS=-fgnu89-inline ./configure \
- --prefix=/usr \
- --sysconfdir=/etc \
- --libexecdir=/usr/lib \
- --localstatedir=/var \
- --disable-static \
- --disable-debug
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --disable-static \
+ --disable-debug
make
}
package() {