summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTed Alff2024-05-08 00:10:17 -0400
committerTed Alff2024-05-08 00:10:17 -0400
commitdaf89466e4a4247de28bcc5168617e5ae0903393 (patch)
tree4c99c5b5f4bcf1e0b670b44fc190d5017ffd64f3 /PKGBUILD
parent6fd66a095d9208a7bfd1a94a9390f616897f8a06 (diff)
downloadaur-daf89466e4a4247de28bcc5168617e5ae0903393.tar.gz
Repo now contains a git submodule; init and update it to build.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3e0d69579362..5284ce5baa51 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=xfce4-power-manager
pkgname=${_pkgname}-git
-pkgver=4.19.0+2+g6c3e56dc
+pkgver=4.19.2+31+g239faf65
pkgrel=1
pkgdesc="Power manager for Xfce desktop"
arch=('x86_64' 'i686' 'armv7h' 'aarch64')
@@ -10,7 +10,7 @@ url="https://docs.xfce.org/xfce/xfce4-power-manager/start"
license=('GPL2')
groups=('xfce4')
depends=('libxfce4ui' 'upower' 'libnotify' 'xfce4-notifyd' 'hicolor-icon-theme' 'networkmanager')
-makedepends=('xfce4-panel' 'git' 'xfce4-dev-tools')
+makedepends=('xfce4-panel' 'wayland-protocols' 'wayland' 'git' 'xfce4-dev-tools')
optdepends=('xfce4-panel: Xfce panel plugin support')
provides=("${_pkgname}=${pkgver%%+*}")
conflicts=("${_pkgname}")
@@ -22,6 +22,12 @@ pkgver() {
git describe --long --tags | sed -r "s:^${_pkgname}.::;s/^v//;s/^xfce-//;s/-/+/g"
}
+prepare() {
+ cd "${_pkgname}"
+ git submodule init
+ git submodule update
+}
+
build() {
cd "${_pkgname}"